PMDG DC-6 electric problem

Hello to all,
Since the hotfix2 update my dc-6 is unusable, is it only me in this case?
I’ve uninstalled and reinstalled it but nothing has happened.
I’ve uninstalled it and reinstalled it but it doesn’t work. Once in the cockpit, without even putting any power source, all my circuits burn out one by one, the circuit breakers above the cabin door cut out one by one, nothing to do.
I haven’t read anything about it or missed it, anyone else have the same problem?

The DC-6 has been upgraded for SU5. The latest version is 2.0.36.

This is the problem, I have the 2.0.36…

I don’t understand where this is coming from, I guess it’s just me, but I don’t see what. :sleepy: :sleepy:

This is the “joy” of having this complex aircraft! You might wish to start with the POH Chapter 9, page 94 to learn everything about the DC-6 electrical system. Or you check with the folks at PMDG.

Thank you for the advice, I may take the PMDG option, I may have misspoken on my first text of the topic, as I am not a native English speaker, and I speak English like a French cow :stuck_out_tongue:, having the dc-6 since its release without any problem of this kind, that’s why I will take the PMDG forum option


well, problem solved,
I uninstalled the DC6 again via the installation utility and removed all traces of it from my hard drive, reinstalled, no more electrical bug. :grinning:


Hey, so I might have a related problem (since SU5). The Garmin doesn’t “light up” unless I hold right-click on the mouse. When I release the mouse button, the Garmin disappears. It also effects my Saitek multi-panel the same way. No lights unless I hold the right button on the mouse. Doesn’t happen on any other aircraft.

Anyone else see the same issue, thoughts on how to fix?

I, but this is a problem with all asobo and pmdg planes, if I hold down the right mouse button, not a single command works. I don’t have a radio panel or other saitek, so I can’t tell you, sorry.

I’ll try your re-install method and see if that works

1 Like

send me a feedback, if still the same, I advise you to look on the PMDG forum and if you do not find anything, send a ticket to PMDG, they answer quickly

Hey !!! Great news, doing the full reinstall seemed to work. Thank you my friend!

1 Like

Great!! you’re Welcome! :slight_smile: :+1: