Poor Performance with Top Hardware

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

Using only official content

Brief description of the issue:

My system is below. Basically the strongest machine available today. On the Low End preset I get 30fps and on Ultra I get 23FPS. This doesn’t seem right. My NCP settings are all set to default.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Any game scenario has this same performance. I’m using the Caranado PC-12 at KLAS for this test.

PC specs and/or peripheral set up if relevant:

i9-13900K RTX 4090 GPU and 64GB DDR5 5600MHz RAM running a 4K monitor.

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

hi @SharpeXB ,

We’ve moved your topic into the User Support Hub.

The Bug Reporting Hub is for posting suspected or confirmed bugs that other users are able to reproduce without duplicating an existing bug report. Using the template or providing all the relevant information about your bug and sim setup is required in order to provide valuable information, feedback, and replication steps to our test team.

If you are not sure if your issue is a bug or need further input from the community, please use the User Support Hub category. If the community can replicate your issue, first search the Bug category to see if there’s an existing topic. If it already exists, contribute to that report. Duplicate bug reports will be closed.

If you believe it is a new report and no duplicate exists, then create a new bug topic using the provided topic template.

All issues caused by or involving third-party addons/mods should be reported to the third-party developer. Assure that no addons/mods are used when reporting issues in Bug Reports.

DxDiag.txt (107.1 KB)
added my dxdiag

What troubleshooting / setup tweaks have you already tried? I have the same pc specs and it runs significantly better than 23-30fps, which indicates your cpu is struggling for some reason.

Suggestions to try (if you haven’t already):

Disable hyperthreading in BIOS.
While you’re in the BIOS, ensure XMP is active & at max speed.
HAGS & Game Mode turned off.
Resizable BAR enabled.
Live traffic off.
Multiplayer off.
Live Weather off.
Run in fullscreen mode.
Shut down all but essential background apps.
Try switching between DX11 & DX12 (I find 12 is better, but it’s not the same for everyone).
Try the in-game FPS counter available via Developer mode, to see how changes to in-game settings affect frames.
Are thermals all OK, with no throttling?
Try with G-sync / V-sync on or off.
Empty or re-name your Community Folder, to try running in plain vanilla mode with zero add-ons.
Temporarily uninstall your marketplace add-ons, as these can also occasionally cause issues, and try the same flight with one of the standard in-game aircraft.
Try significantly reducing the TLOD & LOD sliders - these have a large impact on the CPU.
Remove any overclocks, particularly to the CPU, and run at stock speed.

Screenshots of your graphics settings might help to dig further, but I hope one or some of the above are helpful.

1 Like

Terrain LOD and AI Traffic (especially external traffic mods) are CPU killers and with a RTX4090 you are liable to be CPU (main thread) limited in MSFS.

If that’s the case then at some point the CPU can’t keep up with the game’s demands and FPS tanks rapidly. You will see that as ‘Limited by Main Thread’ and a lot of red curves in the internal FPS counter.

Most other graphics settings only tax the GPU, so you can put them on Ultra with a 4090, but no matter what CPU you have you will most likely always have to make a compromise with LOD and traffic.

I have a 7950X3D, 64GB DDR5 and a 4090 and never go over 200 TLOD and keep traffic low too. Depending on the addons I use (100+ of them usually) I normally get a comfy 30-45 FPS.


I have exactly the same spec as you, @SharpeXB. On Ultra presets I can usually get somewhere between 30 and 100 FPS (vsync off), depending on where I am in the world, how complex the scenery is, how much AI traffic there is, whether I have multiplayer turned on or not and if so, how many player models there are in the immediate vicinity. I lock frames at 30 via vsync, so my goal is to maintain 30 FPS everywhere. Generally I can manage this, but I do still have micro-stutters and long frames under heavy load, particularly where there are many aircraft models present, at big airports or major cities.

As @MrWoof9575 has mentioned, you will most likely be CPU-limited. Have you checked the FPS counter in developer mode to find out? If not, do so to confirm. If your CPU is too busy to supply frame data to the GPU, it doesn’t matter how awesome the GPU is, your FPS will tank. Because MSFS has a main thread that coordinates everything and it’s frequently bound on things like I/O so it’s not running at 100% all the time, the other threads in the sim are bound on the main thread, and things will slow down as the main thread becomes blocked. You can see this if you watch performance graphs in Task Manager etc as you fly - no single core will be hammered at 100% because the main thread simply can’t saturate a core on a CPU as fast as yours.

The FPS-killing effects of complex scenery and large numbers of other aircraft - AI and multiplayer - get much worse for me as TLOD goes up (and to a lesser extent OLOD). TLOD is basically draw distance, it controls how far out the sim will attempt to render detail. To maintain 30 FPS in central London or other major cities like New York, for example, I have to run TLOD 100. Any higher and I start to stutter. If I attempted to run higher TLOD on the ground I would get frequent long frames and stutters and my FPS would drop below 30. What’s your TLOD setting? Also, DX11 or DX12? Because you want DX12 for the 4090.

You mention you get 30 FPS on Low-End presets. That’s definitely not what I’d expect, unless you have vsync on at 50% refresh rate, in which case you’d never see more than 30 FPS. Have you looked at the FPS with vsync off? Do you have a variable refresh rate monitor (Gsync or Freesync) and if so, do you have VRR turned on? Changing preset mostly affects settings that impact on your GPU. It’s TLOD and traffic levels that most impact on your CPU.

What FPS counter are you using to get your numbers? Do you have Frame Generation turned on? Do you even see the option for FG in the sim? Provided you have a VRR monitor or you’re willing to deal with tearing due to lack of vsync, FG would literally double your FPS.

Basically (and sorry for the long post, but detail is important IMHO) you should be able to get a smooth 30 FPS everywhere with your hardware provided you make concessions on TLOD and traffic levels. Because I do, on Ultra presets, with the same hardware, at TLOD 100. You definitely won’t get a smooth 60 FPS everywhere, though you could get it in a lot of places.

If you can’t exceed 30 FPS on Low-End presets with vsync turned off and TLOD at 100, then something is definitely wrong.


I agree with the two excellent posts above, and don’t have anything to add to their troubleshooting advice except these two things:

  1. You mentioned you have NvCP set to defaults. Try setting them to this:
    (Click on the picture to see all the settings. Also, you might have a smaller Shader Cache. That’s OK. I set mine to 100GB after following the procedure for clearing the shader caches.) And you’ll note that Anisotropic Filtering is set to 16X in my NvCP. Turn it OFF in the sim.

  1. Create and enable ‘Ultimate Power Plan.’


If you don’t see the Ultimate option:

Open a Command Prompt as an administrator.

  • Click Start, type “cmd” into the search box, right-click the Command Prompt result, and choose “Run As Administrator.”

  • At the prompt, type (or copy and paste) the following command and then hit Enter:

powercfg -duplicatescheme e9a42b02-d5df-448d-aa00-03f14749eb61

You should see this returned:

Command Prompt executing a command to enable the Ultimate Performance power plan.

If you already have the Power Options window open, you might have to close and reopen it before you see the plan appear, but it should be there.

1 Like

As you are using V-sync controlled by application at Nvidia panel double check that you have not set V-sync to ON with a 30fps cap or something like that in game settings.

The best would be to test the following: force V-sync to ON at Nvidia panel and disable V-sync in game. This will allow game to run up to your monitor max refresh, resulting in the higher posible fps. If you have higher fps there then you need to review the V-sync setting in game you used before and eventually set it with a 60fps cap in game, using the “controlled by application” setting again at Nvidia panel.


I’m not much of a PC expert so I’d rather not go down the rabbit hole of experimental tweaking like messing with the BIOS etc. I can run other games like DCS at 120FPS. My temps on the CPU and GPU are perfectly normal, I don’t think the CPU gets over 51c Disabling HT would only help that CPU temp and mine is fine. Same with overclocking. I have my CPU at 6.2GHz with no trouble. Nothing gained by changing that.
As for game settings I’m using the Ultra or Low End presets. I have a 120Hz G-Sync monitor so I have Vsync off. I don’t think that has anything to do with the problem.
A culprit could very well be add-ons and I am suspecting GSX Pro. I’ll try removing that and see. Yes I know the hit from Live Weather and traffic. Currently I had Live Weather On and AI Traffic On. Multiplayer Off. Those might affect things a little. I’m still curious how a machine like mine gets 30FPS on the Low Preset.

Yes I understand that. The Devmode counter says I’m CPU limited.

No, for the propose of testing it wouldn’t make much sense to have that on. Honestly it’s the only setting that makes the game playable except it adds flickering to cockpit displays. So it’s a no win situation.

I’m using a 120Hz G-Sync monitor so I have Vsync disabled. I do have a frame limit of 118 set in NCP

Frame Generation is a GPU feature and won’t help you squat if you’re heavily CPU limited. If the CPU is so overtaxed that you can’t run the game fluently with a 4090, frame generation will do nothing to change that since it doesn’t solve the actual problem you’re having: not enough CPU power.

Ok. So you have to try to balance things out. Your 4090 is absoutely the power house in your computer, so you load a lot of work onto it.

My method has always been:

  1. Put graphics settings on Ultra
  2. Reduce TLOD and OLOD to 100
  3. Disable live weather and all traffic
  4. Activate VSync to 50% or 33% of your monitor’s refresh rate.
  5. rename Community folder

You should now get FPS in the 50ies to 60ies range outside of photogrammetry areas. Not sure with the Intel CPU.
Now slowly increase LOD and traffic settings until it works for you.
The best would be to get your system to GPU-limited, but with a 4090 that’s a tall order from my experience unless you keep TLOD very low and traffic off.

This actually works although like I mentioned it creates some artifacts. The boost won’t show on the in-game frame counter since it’s done outside that. But if you turn on a counter like the one in GFE you’ll see the frames.

1 Like

I’m using Windows 11 so I don’t think I have that option, mine looks like this.

in any case changing those power modes in NCP makes no difference

The only things that seem to affect performance are changing the live weather and/or traffic. But that still leaves me at 35-40 FPS on Low-End and 20ish on Ultra. And that means looking at a rather empty game with dull graphics on a very expensive PC. Frankly you need the live weather because the other weather options are greyed out (broken?)
The only remaining choice is to enable the Frame Generation, but the flickering is pretty distracting.
FS2020 is approaching the end of its life so perhaps this isn’t worth worrying about so much, I just hope they do this better on FS2024.

I have Windows 11, and I have the Ultimate Power Plan enabled.
I had to run the command prompt script I showed you above get ‘Ultimate’ to show up in the list.

This short video will show you how to choose a power plan.
Again, if ‘Ultimate’ doesn’t show up, then you have to run that command prompt script to ba able to see it.

Ah that jogs my memory. I’ve tried that before and again this time. It doesn’t really make any difference.

1 Like

Oh, ok. In this case Vsync and Gsync (yes both) have to be forced to ON at Nvidia panel and you should not use any frame cap, unless you still want it for some reason, as this is not needed with Gsync.

Game is a borderless window, not true fullscreen, so Gsync does not work well in all cases until you force Vsync too at Nvidia panel. You have to do it at the global profile.


Also, make sure you have variable refresh rate and Optimizations for windowed games turned on in Windows as per below: