Post SSD Failure - CTD - Check Asobo Official Folder for file integrity?

I started CTD’ing on Friday - I’ve been trying to get up in the air ever since.

Friday I took a flight in the morning, shut down the PC and then tried to go flying later that day and MSFS CTD with the blue bar about halfway along the London Screen on Startup.

Last few days - just trying various things - Uninstall/ reinstall/ Repair/ Reset Store/ Logging In/ Out of Xbox/ Store - basically all the stuff that’s been helpfully posted here and elsewhere.

Today I download Magician for Samsung SSD - and it found faults. The SSD is bricked.

As a result I moved the Asobo Official and Community folders to a third SSD with a clean bill of health and uninstalled/ reinstalled MSFS 2020 and pointed the Download to the new SSD where I had copied files from the old sick SSD. (I’m on a Mobile Internet connection here and downloading the whole lot again is a pain I’d like to avoid if at all possible)!

Story short; With the SSD bricked I now wonder - after four days of diagnosing - whether some of the Official Asobo files - which were on that drive, have been corrupted by the dying SSD.

(What MADE the SSD die at only 6 months old - which had ONLY MSFS 2020 on it - is a moot point at this point)

My question is; is there any way I can scrutinise the file integrity of those Asobo files to determine whether the dying SSD corrupted any of them on it’s way out - which is leading me to the CTD on the Startup Screen.

Thanks in advance.

You can’t verify files/folders (yet) you can use something like ProcessMonitor to check what files it is trying to access and delete the folder where a possible error pops up. Or delete folders like fs-base, it will download on startup, it might save you from re-downloading the whole sim.

1 Like

I’m finally back in the air in MSFS 2020 - turns out a corrupted fs.base.nav file (which had Write access .XML files within)

Anyone freezing on half way along (just after Checking for Updates) blue bar on Greenwich screen should go to Folder; Official - OneStore - and delete fs.base.nav.

Restart the PC and start MSFS 2020. You will have to download that file agin - approx 750 meg.

Restart again when it’s done. Hope this helps.

Thanks for sharing this, I think I’ve had a similar issue to your freezing. I unintentionally transferred several gigs of files onto my MSFS/FSX SSD and ran it empty.

After showing “0kb Available” for the drive, neither MSFS or FSX would run. MSFS gave me a completely useless error message but I was 99% sure it was drive related because FSX now says it’s not an activated version - both problems started immediately after maxing out the drive.


I was able to fix MSFS after a lot of messing about but have been suffering a 1-2fps joyride shortly after take off so hopefully this may help.

(FSX is still broke :frowning: )

1 Like

I was half a thought away from reloading FSX today until I stumbled on this idea of File Corruption within the Official-OneStore Folder, etc.

Still tempted to go back to FSX because I have Javier’s Nimitz and a perfect VTOL Harrier (with Tackpack) , etc as well as A2A Cherokee for more benign bimbles about in the sky.

Either way - good to get back up in the air in MSFS 2020. See you up there. :slight_smile:

This really helped me - Using Resource Monitor on DISK and RAM I was able to scrutinise two files that repeatedly appeared to stall on loading in to RAM.




I deleted them. Restarted the PC and started MSFS. Got to the Updates screen and they downloaded - and now I’m flying again.

1 Like

Glad you got it solved. :flight_departure:

1 Like