[POTENTIAL TIPS] Something to check for 16GB ram users to massively improve freezes and stutters

I thought I’d share a “stupid” thing that happened to me that caused huge one or two seconds freezes and a lot of micro-stutterings.

Here’s my PC: I7-4790K, 16GB ddr3 ram, MSFS on SSD, GTX 1070

I used to have massive freezes of one or two seconds, especially the more the detailed an area was. Also had a lot of stutterings impacting FPS as a whole. However I was very pleased with FPS when it didn’t happen.

I tried tracking down the issue with no luck, up until I heard the faint noises of one of my HDD running multiple times. It gave me the idea to monitor all my drives using Windows built-in Resmon tool. Guess what I found? Each time I experienced a huge freeze or too much stuttering, one of my HDD was running at 100%.

So it rang me a bell and of we go to the virtual memory parameters… See, when I installed Win10, I never bothered to fiddle with virtual memory as it’s common practice to let Windows manage it. Well guess what? Windows found it clever to set pagefile.sys (the pagination file responsible to handle things that excess your amount of RAM) on one of my HDD that I used solely for data storage, despite me having 3 SSD. And it chose the slowest of the 2 HDD no less! An old green one running at 5400RPM!

So I changed that HDD virtual memory parameters from “managed by windows” to a set minimum of 0MB and a max of 0MB (otherwise, for odd reasons, it wouldn’t delete the pagefile.sys if I just use “no pagefile” on it and would continue using it) and put something like a min of 15GB and max of 20 on one of my SSD, so Windows would now only use this one for virtual memory. Restarted.

Now we all know that MSFS is quite RAM hungry and 16GB is not really enough (monitor your RAM usage when it loads a flight! It will go past your 16GB and use virtual memory a lot) and guess what?

No more freezes, much much less stutterings saves for the occasional drop to the 10-13FPS when it streams large chunks of data. Game is much smoother now! With the exception of very detailed and crowded area like New York or London, I get a solid and mostly smooth 35-42FPS on ULTRA, 1080p, cars and boats to the max, live weather and traffic, render 100. Loading times are much better too.

It is night and day. So please double check that your Windows 10 has had the clever idea to put virtual memory on your SSD rather than on one of your HDD!

Also, I think I saw MSFS still using virtual memory a bit even when RAM wasn’t full, hence the freezes and stutterings everywhere too. So it might also be applicable to 32GB users.


Thats awesome to hear!! I haven’t messed with Virtual Memory much, would you mind screenshotting what the settings look like for you? I also have 16GB of RAM. Thanks!


My system is in french so you’ll have to go through your own comparing the look side by side to get the corresponding meaning:

  • D: and E: are two partitions of the same HDD named “HDD1”
  • F: is the sole partition on my old green HDD called “Terra1” that I only use for data storage. It is where Win10 chose to put the virtual memory file (pagefile.sys file) which was a catastrophe in case of excessive RAM usage as it often happens in most flight sims.
  • C: you don’t see it on the screenshot but is an SSD where Win10 is installed
  • G: and J: are two seperate SSD, J: being the largest of the two. MSFS is installed on J:

Virtual memory is now set to be on J: . As a general rule, you can use this rule of calculation to get a good result of what to put: (here for 16GB of ram) 1024 x 16 x 1.5 = 24 576 (24GB). So I put values around this, 20000 for min and 25000 for max.

Made a huge difference, but it is a trick and a specific scenario that may only apply to a handful of people. Something to double check if that applies to you or not, but there may be more people than you’d think that would be in the same situation and wouldn’t be aware of it.


+1 on this fix. Used to have 16GB RAM, pagefile on HDD. Switched the pagefile to SSD, and now MINIMAL stutters. Very smooth, after initial load-in stutters all is buttery smooth, even in photogrammetry areas such as KBOS. Performance difference: before, HDD was constantly at 100% and RAM was around 15.8/15.9GB. Now, RAM sits at around 14.9/15.0GB and HDD varies to around 15-30% with some spikes. Overall way better performance. Thanks so much, you may have just saved my sim until I can upgrade to 32GB RAM.


Have you also gone into BIOS and made sure that your XMP (or AMD equivalent) is turned on in order to enable the full speed of your RAM? Just sayin.

1 Like

I had already changed it to system managed for all my drives which solved my 1-2 fps around San Francisco airport and reduced the stutters. Yet I see Windows still has a 3GB page file on my HDD (and 18 GB on my SSD) Thanks for the tip, I disabled the one on the HDD, lets see if that will remove more stutters.

I had an epic stutter today

Drone mode still responded to rotating, the plane got redrawn the rest stayed the same, trippy. After 10 seconds the game resumed as if nothing had happened. It just needed a little break.

I can vouch for this. Very similar specs to the OP and it was a literal game changer for me. If you’re having performance issues this is definitely one to try; it’s one of the quickest and easiest changes to make!

bro i have your cpu with a 2070.
First thing, i had to delid and to push it to 4,9ghz at insane voltage to get low stutter and decent fps
Increase the rendering in 1080p, so you will get more usage from the GPU and your cpu will work better.
I swapped from 16gb ram 1600mhz, to 32gb 2400mhz, i got BIG fps increase