Problem activating VR Mode

Anyone else having trouble getting FS to switch to VR Mode?
I have the latest NVIDIA drivers, Beta turned on in Oculus app, using a Oculus Quest 2 headset.
Have OpenXR installed with right regedit string.
Connecting via Oculus Link.
In headset, go to Desktop mode and see the laptop PC desktop and hear the FS music.
FS detects have VR hardware as offers the CTRL-TAB option, but when try it (even by Options menu),
it does nothing. No error messages.
Spent weeks reading every forum post and YouTube to no avail.

Can you see the test OpenXR scene?
You can launch it from the first tab.

Have you tried it without Beta, ie vanilla Oculus?

I don’t use Beta and it works fine.

OpenXR is set to Oculus isn’t it - in the Registry settings. Not Win Mixed Reality.

Yes, can see the Open test scene, but it shows as double images in the headset.

Thank you for responding.

Just tried it (turned off beta) and same thing.
Yes, registry set to the oculus json file and the right path.
Wonder if starting in right mode?
I turn on Oculus Link, then Deskop from the in-headset console menu, see and hear FS in the floating curved window, the try to switch to VR mode and nothing happens.
Thanks!

Have you tried re-binding the keys to toggle between VR and 2D?
Not saying it’s necessarily the problem but a very quick and easy thing to try.

Thank you for the suggestion. I can give that a try, though with the default, when I press them, the option highlights, so it appears to acknowledge it. I also tried to switch to VR in the settings.

Fair enough - never hurts to try what seems to simple to be true though. A bit like checking your kettle is actually plugged in when it does not work. :slightly_smiling_face:

Why did you install OpenXR? It’s only for headset other than Oculus like WMR ones (G2, etc.), so for you it’s useless and mess up things (I have an Oculus headset). Uninstall it, and the registry should point on the Oculus directory JSON file.
Check my installation below, but be careful, be sure your driver letter is the good one (probably C). Mine is on my D drive so change it accordingly.

Thanks much for taking the time to help!
I had tried that before, and just did again unstalling OpenXR, ensured registry still had entry, started Oculus and connected via Link, brought up desktop mode and started FS.
I can see the curved desktop in the headset and hear the FS music or plane engine when in cockpit.
It gave me the option to switch to VR mode, but alas, when select it, nothing. Also tried from options menu.
Also went back to Oculus Beta, restarted FS and same thing.

I assume if it did work, the headset view would go full screen?
Its currently in a curved window view of the desktop with the floating options bar below it.

My oculus link connection is solid, plus also tried Air Link.
Are there any FS event/error log files I wonder that might give a clue?
Maybe something in Developer mode?

Thanks,

Try running the Oculus fixer.exe program in the diagnostics directory first. Then in the Oculus software run the USB test and report your link rate. Mine varies between 1.8 and 2.3 gb/s and is very solid.

Once verified, quit the USB test, fire up FS and see if it can get into VR.

Capture
2.5g

ran fixer.exe that then started oculus.
started FS and switch to VR still nothing. Do not get the split screen on the desktop.
I do see the screen flickers once very briefly.

Are there any log files created that might give a clue?
There is something fundamental not working or I’m missing.

thanks again,

FYI got it working! All it took was a new laptop. Apparently my 2060 CPU (mobile) was not up to the task. Would have been nice if FS would have given a message instead of ignoring switching to VR.
Got a ASUS - ROG 16" WQXGA 165Hz Gaming Laptop - Intel Core i9 - 16GB Memory - NVIDIA RTX3060.
Thanks everyone who offered help!

1 Like