Problem G2

Hi everyone:

Sorry for my English, I am Spanish.

I have a problem with msfs and Reverb G2.

Moving my head to each side, I have little jumps when I look straight ahead again. The jump is always when looking forward again. Does anyone else have the same problem?

If I am looking to the left and look forward again, the image stops for 1s when I look forward again.
I’ve tried various settings and it always happens to me.

38 FPS Average
OXR 70% repro off
MSFS 100% TAA

My hardware:

i7 11700k 5Ghz
48 Gb RAM
1Tb SSD
Geforce RTX3080Ti

Tnkhs

1 Like

Try turning HAGS off. Maybe it helps

1 Like

too high settings, good be anyone of them, you need to know all of them, set every thing low-er (but texture resolution = ultra) and find the culprit

sounds like fps drops…
does it happen more when in complex scenery and/or using complex aircraft?
do you have terrain pre caching set to ultra?

Switch on Dev Console - take your headset off and simulate the movement you describe by holding your headset and rotating - the dev console on your monitor should give you your fps and what is your bottleneck.

Windows 11
HAGS off and Game mode: off
My settings are the same as “VR Flight Sim Guy” youtuber.
With any plane and pre-caching=ULTRA. I have tried with medium and same result

In DEV console, it appears blocked by mainframe and GPU. Turning your head, drops FPS and GPU latency, but only 1s. But only by looking forward again

I have tried 80 render and TAA, but same result.

How is your lighting in room? maybe it is too dark on sides, then screen is bright and that messes up tracking of headset, or something similar? Try to check in WMR home with controllers turned as “flashlight” - that will show you passtrough everywhere you poing your controller.

I have good lighting. It is true that the monitor gives a lot of lighting and I’m close to him
I will try with the controllers.
In the windows mixed reality and steam environment, it doesn’t happen.

My thoughts:

  1. This is how the cable problems of my first cables developed. If it just a jump, then maybe no problem, if in addition you get intermittend blue imaged drop outs, then it be the cable
  2. I second the lighting possibility from above, the head tracking is sensitive
  3. You could try to re-trace your room boundaries in WMR, sometimes this helps for me. I do not know, how much and which “visual cues” the head tracking finds, stores, uses and needs. But sometimes my feeling is, if things change to much from your last room tracing scan, it becomes more unreliable.

What I have noticed is that in 2d when connecting the headset, there is a drop of 10fps. Only in Windows 11, in windows 10 it did not happen to me.

Without the headset, in 2d I have about 45fps all in ultra and 4k.

I got a 50% fps hit when i upgraded to W11. I found a youtube guy that helped me get back to 40fps in ultra. Ultimate Windows 11 Gaming Performance Optimization Guide - YouTube

Ive been looking hard at the G2. I currently run the Rift S. In order for me to get smooth movement I have to cut my graphics settings back so far that I cant even see the airport until I have my wheels down for landing. Sure I can see the lights and strobes of the airport far enough out. BUT… in VR I can only fly VFR. I cant see my dash with the headset on. The process of feeling around to set my radios and autopilot just kills the VR immersion. Flying a CUB with a Hotas in VR is the ultimate. Would be the ultimate if I could see the airport on the horizon. Im still looking for that ultimate HMD.

I already saw the video and I already did what I was saying.

I swapped the odyssey + for the G2 and I’m happy. Everything very clear, the instruments are perfectly read. The only problem is that jump when looking back to the front.

I’ve have the same issue, either the lights are to dim in the room or reset the G2. Unplug it and plug it back on out the headset on follow the G2 tracking (up, down, left ,right). Once’s that’s done now get into msfs in VR. This fix it for me and if not reset everything.

Maybe try clearing out tracking data in WMR - perhaps some corruption in W11 upgrade process…

I think it’s the cable. I have the headset connected to usb-c, I have tried with the usb-c-usb adapter and the same result. I have put more lighting, I have installed everything again and same result.

Turning my head, the image and black screen stopped for a second.
What do you think?

I’ve got same specs and same issue.
I originally thought it may be the R1 cable but HP assured me it’s ok with my intel chipset.
HP even exchanged the headset thinking it was defective. New one was the exact same.
WMR update helped smooth out some things. I turned off HAGS (didn’t realize it was on) and that helped incredibly. As soon as I increased my FS in-game settings, it started to skip and twitch again. Right now, my Q2 is much smoother than the G2.

I have noticed that in 2d the same thing happens when turning the camera. I see that going back to the center, the GPU latency shoots up a second. I’m lost.