Problem with a logitech g (saitek pro) throttle quadrant

I’ve a problem with my logitech g (saitek pro) throttle quadrant. I can’t switch flaps between positions. Only complete increase or decrease. I tried to calibrate in MSFS but didn’t succeed. Who else has such problems? how did you fix it?

1 Like

Check out this video!

1 Like

Perhaps you’ve already tried - but worth checking all working ok by typing joy.cpl in Windows start menu - this allows checking of calibration etc…

1 Like

How do you move the flaps one setting at a time? I have ask this question and I have seen others ask this question. Here is how I solved this problem for myself.
I am using the Logitech/Saitek Throttle Quadrant.
The toggle switch under the Mixture lever (red handle) is T5/T6. Pressing the switch up is T5 and pressing down is T6. I assigned T5 to Decrease flaps and I assigned T6 to Increase flaps
If I want the flaps to move only one setting I press and release the toggle switch. If I want the flaps to move all the way either up or down I hold the switch longer.
Hope this helps anyone like myself who is just starting.

1 Like

Thank you) I watched the video and it helped me. The problem is fixed.
Your settings should look like this:

1 Like

Any idea why my Logitech Flight Throttle Quadrant won’t show up in the sim like the picture above? I’ve for the 64-bit Logitech drivers and checked with joy.cpl that all the axis and buttons work. MSFS 2020 just doesn’t see it. It’s the Steam version if that makes a difference.

I have a problem with my quadrant too.
The game recognizes the system, and rudder and yoke are both working.
But when I push the throttle to give some power, nothing happens.

Thanks in advance

@ Ibims1Jonas


maybe your axis are inverted so this can be common problem.

Already tried that wasn’t the problem

Are you in the SU7 Patch Beta?

Some aircraft now only respond to Throttle 1 axis mapping, not Throttle.

What is the SU7 beta? :sweat_smile:

I tried to change it but my throttle still makes a reverse thrust

Hi Everyone,

My Saitek throttle quadrant keeps going into inverted mode all the time. If I change and save from the control menu, once I go back to the game it inverts itself. I have also tried removing the device from the control panel. Help, please.