Problems with JF Arrow III after update SU-5

Hi all, what is happening to me is everything looks great until I rotate, I then loose all joystick and rudder peddle input. The plane just climbs out on its own in a straight line. Totally repeatable.
Any ideas? (auto pilot is off as is the AI fly the plane option)
Go back into the sim and check control sensitivity and there is no input.
Edit: Only happens from a cold and dark start

I’ve had issues since release with their controller interaction. Nearly every time I start a JF plane, my controls are unresponsive, even though if I go into options controllers, my controllers actually register as active. Mostly it’s been my Throttle quadrant, which I have plugged into a powered USB bus. As I noted, the controller registers as active in options, but not in the plane.

To fix it, I unplug it and plug it back in. That usually fixes it, but, many times, the whole sim goes unresponsive for a minute or so after I plug it back in, then it comes back and everything is hunky dory from there on in. This is pre-SU5. I’m downloading that now.

Just discovered that it only happens from a cold and dark start. If I spawn on the runway engine running it works fine. Not sure what is going on.

1 Like

That makes sense, I always start cold and dark. I’ll bet SU5 amplified whatever problem I was having previously. Is your controller plugged in directly to a USB port or an external bus. Could that be the issue?

My quadrant is my only controller not plugged into the back of my computer. Ports on the front are usually bus plugs, and sometimes not even powered.

Airbus controller plugged directly into powered USB ports as are the rudder peddles. So no weirdness there. Scanning the forums looks like cold and dark may have some systemic problems because I also had it happen with the stock 172.

Just making sure, you just said powered USB ports, which tells my they’re not into direct connection USB ports on your motherboard. Unfortunately, the state of USB implementation is pretty poor, nobody designs them the same (even direct connection ports can have issues), so, just because it’s powered doesn’t mean it’s good. I’m not saying they’re bad either, but, USB bus ports are notorious for issues, powered or not. Try plugging them into the back of your computer directly to the motherboard connectors.

Granted, I wish it worked, but this is very often a problem. Also, try unplugging them when you lose control and plugging them back in. That may reestablish the connection.

As I noted, my only controller that isn’t into my motherboard is this quadrant, it’s a good quality bus that is powered, and it’s my only controller that has issues.

Do a little googling on USB standards and quality.

Toggle parking brake is not working for me. It just pushes it in and out but doesn’t actually toggle it set or released position and stays put. I am using T.Flight Hotas X.

Can confirm parking brake toggle not working correctly. Additionally, you cannot open the side window, you cannot adjust cabin heat and vent. I’m sure there are a few other minor issues which will probably be sorted fairly quickly.

To be fair, ALL 3rd party aircraft have issues post-SU5. E.g. Mooney trim is reversed, CRJ cannot toggle HUD, CRJ interior lighting and shadows are horrible, etc…

1 Like

Yep, got an email from JF they are aware if the issues and will get us an update as soon as they can. Ah well nothing goes smoothly in love war or software.

The mixture control also does nothing haha. The update is a total disaster. I have been testing and using msfs since alpha and this I by far the most unstable update so far.


Aah thanks for the post. Just tried the Arrow Turbo and noticed my mixture control only moves from max down a little bit towards centre with my throttle quadrant. I can move it with the mouse but that just bugs me!

1 Like