Progress bar stuck at ~70% on load screen after flight selection

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

After selecting flight (aircraft, airport) and clicking Fly, the loading screen gets stuck at about 70%.

Provide Screenshot(s)/video(s) of the issue encountered:

The progress bar advances quickly to this position, then gets stuck indefinitely.

Detailed steps to reproduce the issue encountered:

Open MSFS, Free Flight, select any aircraft/airport, click Fly. A load screen appears with a progress bar. The progress bar gets stuck at about 70%.
This did not happen in the past. Even 3 weeks ago (Mid-may), the sim ran flawlessly.
Since then, I installed WU9 and Maverick. I now uninstalled those but the progress bar still gets stuck.
When I start in safe mode (no external mods), I get the same result.
I regularly update my Asus X13 so that may have been a cause.

PC specs and/or peripheral set up if relevant:

Asus ROG X13 Flow, Ryzen 9 5980HS with 32Gb, RTX 3080 with 16Gb

Build Version # when you first started experiencing this issue:

1.25.9.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

After uninstalling and reinstalling Flight Simulator 2020, and installing no add-on, no world update, no nothing, I still get the progress bar stuck at 70%.

Upon further investigation

Console when loading MSFS is complete (Main menu):

Then, when selecting a free flight and clicking “Fly”

As the flight starts to load:

A split second later, when the progress bar gets stuck:

At this point, the app becomes unresponsive. The mouse still moves (with the dedicated MSFS mouse icon) but I can’t click or use the mouse wheel in the console. The app won’t come into focus if I select it (by using the task bar or alt+tab) after I put another app into focus. Basically, the app is unresponsive.

The same happens with other airports in other continents, training missions, etc…

Not sure what else to do. Help is appreciated!

I left the sim run for a couple hours, and it looks like it is still loading. It seems to be incredibly slow and unresponsive. Again, this was not the case a few weeks ago, when it loaded very quickly.

Just only os or some other updates?

New addons in community?

No addons from community.

I may have updated Windows via the official update feature.
I am pretty sure I have updated the Asus system via the official Armory Crate software.

Thanks for your support.

Yes maybe,

because there was something changed with your system probably in that time, better say after that correct functionality. Hope this is your problem and you can easy solve it :wink: good luck

1 Like

I disabled bitlocker, thinking this may have been activated recently with a windows update and slows down SSD I/O. (Hypothesis quite unlikely as I’m sure I haven’t activated it myself recently and doubt it would self activate).

It took less than an hour to decrypt the files in the SSD.

I tried to run the sim again. Same issue. It gets stuck here at this moment.

Adding more screenshots as loading progresses…

Note how the loading process gets stuck 20 minutes on one item.

Up to this point I thankfully have had very few issues as far as CTDs and loading. I guess it was just a matter of time before it caught up with me.

Starting on Wed. I have not been able to load into the sim (fly button). Gets to 70% or 80% and stops responding as noted here. As a side note, when loading the sim itself I am getting a similar issue. It gets to about 80% then the remainder just inches along until it finally loads into the UI. Prior to Wed. it would hang slightly at 80% then after a sec or two it all loaded in very quickly.

I have attempted to reinstall 3 times (working on 4 as we type) with no luck. I have reinstalled Windows, just an over install not a complete wipe.

Here is my question, is there a known reason and resolution for this, and if not does anyone have a recommendation as to whether a full reinstall of Windows could make any difference? I obviously would prefer not to do this as there seems to be nothing wrong with the remainder of my system, just FS2020.

Any ideas would be greatly apricated. Thanks in advance.

PC version, installed thru both MS Store and Xbox methods.

Just an FYI, appears 4th time is the charm. The 4th reinstall worked and everything is back to where it was earlier this week.

The only other thing I did was to change the exe to Run as Administrator as I have seen posted here. Not sure if that did anything or not but everything is working once again.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

i have had the same problem played tuesday last week no probs 3 days later would not load past 70pc had to reformat drive ,install system again and now works fine

still the same problems since a month.
when I don’t have an internet connection everything works, but with an internet connection it always stops loading, and progress bar stuck at 70%, Community Folder is empty,

I am running into the exact same problem.
I was able to play normally until about August 25.
I press the Fly button and around 70% it stops progressing, the music continues to play but the message above the progress bar stops updating.
The mouse also works.
The same thing happens when I put it in safe mode.
I reinstalled Sim but still the same.

Is there no other way but to start over from the installation of windows?

Translated with DeepL Translate: The world's most accurate translator (free version)

Same problem over here too.
The last 14 days after an update MSFS and an Window10 update at the same day I encountered this problem.
It is still a problem but luckily I have Prepar V5 at the ready. But he guys… who has the solution?