Purchase options in game are gone


Microsoft Store version fully updated as of 29 August 2021.

Nothing in the community folder.
Normal sim mode - NOT Developer

To reproduce simply run FS and click to buy something in the marketplace.

I have actually not played the sim in 4 or 5 months. So I can’t say when this error may have started except that when I loaded up the game, did all the updates to be current, and then went into the Marketplace to buy a plane that planes purchase options were greyed out. This is the case with every item in the marketplace in the game.

I have researched this issue and did everything I could find that could help. I made sure my account was correct. I made sure my MS payment information was all correct. Even added a new card to the list of payment options. I made sure the xbox information on my pc was all correct. Xbox networking is all correct and connected. Xbox live multiplayer is working and connected.

The store worked the last time I run FS. I have made many purchases through the Marketplace. This current issue sucks since so much is on sale and I want to buy it before the prices go back up.

Specs: Windows 10 Pro V: 10.0.19042 Build 19042 64 bit
3.8ghz OC’d 5ghz
Gigabyte Z390 Aorus Pro Wifi
1 Gig Optane Memory
32 Gigs Ram
NVIDIA GeForce RTX 2060

I have not submitted this to Zendesk YET.



PS: I can make purchases via the MS Store and the Xbox app. It’s only in FS that all purchase options are greyed out.

Try log out of the MS Store and on the MS flight sim page and inside the sim too
and then log in again all three places.

Worked for me.

I believe this article deals with same issue:
All versions - The Marketplace tab and/or Online services are grayed out – Microsoft Flight Simulator Support (zendesk.com)

Blue skies!

Well, this is fun…I signed out of all those accounts. Launched FS and it asked me to sign in. So I did. Then it said (and says still after 4 launches)

Please Insert Game Disk

When, of course, I can’t, I have to quit the game. DOH!!!

Figured out I needed to sign IN to my account via the stores first. Did this and the game started back up.

However, doing all this still doesn’t allow me to make any purchases. I can get in the marketplace. I can look at all the things for sale. But when I click on an item I am interested in the Buy option is still greyed out.


These pics show that I am online. I have access to the Marketplace. I can open an addon to view it yet the purchase options are greyed out. I just don’t get it. Guess I’ll have to open a ticket and wait a few months for them to reply. (Still waiting on the last 3 tickets I submitted and that was almost 7 months ago!!!)


All versions - Buy & Download button is grayed out – Microsoft Flight Simulator Support (zendesk.com)

I did see where this is apparently an issue that enough people have that they have a help page for it. Since my issue has remained for weeks (well over the 48 hours) I submitted a ticket also. Thank you for the information!!!


You’re welcome.

Try - launch msfs and sign out > sign in.

Submitting the ticket to Zendesk did the trick. They fixed my account. All good now. Of course, I missed the sale on 4 items I wanted. Oh well…


Closing this as the OP has marked as solved. If anyone has similar issues, we recommend checking out Zendesk: