"push button" action ability with VR hand controllers

Please tag your post with #pc and/or #xbox.


Are you on Steam or Microsoft Store version?

Microsoft Store

Are you using Developer Mode or made changes in it?


Brief description of the issue:

For example in the default Cessna 172 with analoge cockpit and Garmin GNS530:

It appears that when in VR, when using the VR hand controllers on the Garmin rotary knobs, the user needs to move his physical hand too hard forward for the “push button” action to work, which also results in frequent accidental and unintended rotary output from the same knob. This also applies for the frequency knob on the KR 87 ADF panel. Subjectively, it feels too much like you’re in a boxing match with the push button knobs.

Arguably, a user might assume that the push function is not working, since the forward momentum necessary is quite significant than considered normal.

Alternatively, could this push botton action with the VR hand controllers movement be more finetuned and subtle, or perhaps more a “button clicking” action, or a new specific hotspot even?

Provide Screenshot(s)/video(s) of the issue encountered:

Not necessary, easily reproducable.

Detail steps to reproduce the issue encountered:

Enter with hot Cessna 172 in 3D. On the Garmin GNS530, click on the " Direct To" button on the right. Now with the VR hand controller, try to " press" the GPS rotary Push CRSR button, which is in the bottom right. Result: the user needs to move quite fast for the knob to detect a press action. This may also induce an accidental rotary output which changes the data values on the navigation page.

PC specs and/or peripheral set up of relevant:

HP Reverb G2 v.1 (2021), 3700X, X570, 32GB 3600, RTX 2080S, SSD

Build Version # when you first started experiencing this issue:

Latest Sim Update as per January 23th, 2022. Unknown where to find the build number in the software.

I didn’t even know you could do this! But yeah, I tried it and it’s just like you said- you really have to jab it fast so often results in a twist motion registering too.

I’ve tried to set buttons as “COCKPIT INTERACTION - SECONDARY ACTION” but could never get it to work. The secondary action button never does anything. It works fine with the mouse- the secondary action button is the right mouse button and using it lets you press buttons (like CRSR). But doesn’t work with Oculus VR controllers. At least not for me.