Quest 2 link stopped working. Looking for answers

I finally was having a good experience with the Quest 2 and MSFS. Decent frame rate and only small stutters. Then, after a restart, I can no longer start Link in the headset. The Quest 2 shows connected in the PC quest software but it fails a USB cable test like it can’t find the Quest at all. When I plug in the Quest to the PC I get no notification that it was connected.

I have the original Link cable and a third-party cable. Neither will work. Both show connected but will not pass the USB test or allow the headset to connect to Link. Both cables will work on my other PC.

I have tried several tips I found online like reloading the Quest software on the PC. Uninstalling the USB driver and restarting. I have gone back through all the settings I can think of but it acts like the PC USB port is not working. Other devices in the same port work.

I also cannot use Air Link. When I try to start air link in the headset the Quest PC software on the PC restarts and turns of Air Link in the settings.

Any suggestions? I appreciate any help.

  1. Check if Quest 2 has “AirLink” option enabled and disable and try again.
  2. Uninstall Quest 2 App in PC and reinstall.

Thanks. I performed both of those and no help.

Ok…maybe you can try in another computer, a laptop or another PC…or try installing OCULUS APP in your mobile and connect wireless

Thanks again. I mentioned in my original post that both cables work on my second computer. Can you explain what you mean by installing the oculus app in my mobile and connect wirelessly? I may be misunderstanding. I can not use Air Link. When I set it up and try to start the connection, the PC oculus app restarts and turns Air Link off in the settings and fails to connect. Thanks again for taking the time to throw out suggestions.

Something similar happened to me when windows update installed the drivers from the manufacturer of the usb chip (ASMEDIA). I uninstalled the driver from the device manager and when the Microsoft generics were installed everything worked again.

If you have set a value for bitrate in the oculus debug tool or OTT, ensure you reset the bitrate to 0 (default).

I had the same problem, and fixed it today, by following the instructions by iinSan3HD on this post:

I thought my cable was broken, and even bought a new one, but it wasn’t. Now I have two cables that both work.

The steps that you pointed me to fixed the problem temporarily. I had the same results where only the USB-c port on the GBU would work. Unfortunately that port has always disconnected after several minutes. After it disconnected I tried a USB3 to USB-c cable to see if it would not disconnect. I also ran the oculus tray tool. One of hose two attempts killed the connection again. I am back to not passing the USB test with the 1971063 error with any cable. I’m going to run through the steps again and try to narrow down what is killing the connection. Thanks for the help.

1 Like

I played with OculusDebugTool to change a few settings, and that seems to have triggered the Link to break again.
This time, I just uninstalled all Oculus software, and removed the two directories, AppData\Local\oculus and AppData\Roaming\oculus, but did NOT bother to purge the Registry. After a reboot, I reinstalled Oculus app, and USB Connection Test passed.
Among the things I changed in OculusDebugTool, before the Link stopped working, was Encode Resolution Width. I’d set it to 4080.
I just re-tested using the OculusDebugTool to set Oculus Link → Encode Resolution Width to 4080. Sure enough, this breaks the Oculus Link Connection again. I’ll just have to repeat the steps above to restore it. I’ve reported this problem to Oculus support.

Thanks for the follow-up Taro. That is pretty much the same experience I had. The funny thing is that the second time I restored the connection I got all of my ports back instead of only the GPU port. I can now use the USB3 to USB c cable and I don’t have the PC disconnect trouble. I wonder if the Oculus Tray Toll would kill the connection also. I may give it a try just to see what happens.