Quest 2 Link super laggy & crashing in 2D (headset issue not PC?)

Hi all,

Not sure how best to explain this but wondered if anyone else has experienced this…

I’ve started experiencing the following:

Boot PC, open Oculus app and Tray Tool.
Boot Quest 2, plug in using link cable, enter Link in headset and select desktop.

Now everything is fine, until I start flight simulator… when the menu appears, the quest 2 is super laggy.
The lag is only in the headset, not on the PC monitor. i can move the mouse around easily, no sign of PC based struggles. In the quest, buttons will highlight when i move the mouse to them but the cursor stutters its way across the screen and its like head tracking is at 2hz. The mouse is taking forever to drag around the screen, if I move my head then the rendering is taking ages to catch up and occasionally the whole quest just crashes to black and I have to unplug the link cable to resolve it.

If the lagginess starts and I enter VR mode in Fs2020 immediately, it’s fine again! Also, if I take the headset off, plan and start a flight, then put the headset on and enter VR, it’s fine.

Anyone experiencing anything like this?


Exactly the same here. Out of 10, happens 5 times. Very annoying!

Yes happens to me also, I use the Oculus controller to select Airports/departure and FLY now.Discovered yesterday if trying to go to VR and I just get the 2 screen stencil and not VR I reset the link again and then its VR.

I seem to have cured the issue, though I’m not 100% why.

See my post with latest changes here:

I suspect the fullscreen changes to the .exe file and running the sim fullscreen on the desktop again. But I’m not sure. Just glad it’s gone away again!

Please use the forum search before opening another topic. There are a lot of topics about the Quest 2 and the link cable.

I did. Couldn’t find a thread related to my issue.

Kindly point me towards a thread addressing this specific issue and I will happily merge my queries into that.


I had this happening to me, I solved it by uninstalling steam VR and launching the game through the headset instead of clicking on it in steam, hope this helps.

1 Like

Thanks Hugo, sadly I never had steam VR installed and had same results launch in HS or out. I read that raising the OVR server priority in Oculus Tray Tool can resolve issues like this, something seems to have worked so perhaps it was this.

I will test later today to see if i can recreate it.

I see, I would like to suggest checking if you get good fps when using Virtual Desktop so you can eliminate a PC performance issue from the equation.

Please tell us if you solve the issue by following the method you found, it seems a lot of people are having a similar issue but the solution seems to be quite different from person to person, I believe there are many different issues causing the same problem: lag while in the link mode.

Am i right in thinking that Virtual Desktop requires Steam VR to work? I’m reluctant to try this as I’m getting stable results now and I’ve read a lot of issues revolving around steam VR. But perhaps I’m just holding onto a comfort blanket unnecessarily…

I’ll certainly try and recreate the lag issue.

I am actually not sure about Steam VR in VD, there is a good chance though, maybe someone more informed than me can help you with that

Bumping this again because it’s come back… super irritating. Anyone found a definitive solution?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.