QUEST 2 not working : blinking screen and out of link in headset

Hi everyone, and sorry if this matter is solved in another post, I tried to search but couldnt find a post that solves the problem.

I cant make my new oculus quest 2 to work properly :

I start msfs and go to VR (ctrl+tab), then I have the dual screen with a message “press space bar” to center"

I start oculus link from the head set, and i have the “floting view” of msfs in the headset.

When I start “fly now” the view is blinking like 1 frame/second on the computer screen, and nothing in the headset. The headset eventually stops link connexion and msfs sometimes crashes to desktop, or I manage to quit the VR on computer.

I have the beta 27 oculus software, but its not working in official version version 26 either, and last version of msfs (NOT STEAM).

Laptop i7 10th gen with RTX2060, and dual screen.

This is very frustrating, I bought the Quest 2 for msfs, but no way to make it work.

pleasehelp :frowning:

I just started seeing the same thing with very similar specs and the quest 2. It was working no more than 5 days ago, and I’m suspicious that the latest update broke it. I noticed in SteamVR debug console that a warning is printed each time the connection drops — “the device sent 2 left images for the same frame!” (Or something to that effect). I don’t have a solution yet either.

Same thing. My friend is also running on a Nvidia gpu and has the same problem. I have been Troubleshooting since days but nothing. I noticed it is linked with nvidia and not oculus and steam openxr or the Game itself. I have tried everything you can imagine

same here, no way to get real VR with Oculus Quest 2
can play only on virtual screen, as soon as I active FS VR with CTRL+TAB, screen is blinking between FS and SteamVR
InGame Steam movie mode is insactivated
(I have no problem playing VR with DCS btw)
Tx for help

Having the same issue - I just posted about it too as didn’t realize this post was here.

So I guess I can stop banging my head against the wall and take some solace in the fact that it’s not just me experiencing this issue.

Same for me, all was working perfectly yesterday and today I had to update Virtual Desktop on headset when I started. Then same issue. From yesterday I haven’t noticed any other update (MFS, NVIDIA or STEAM). I can start the game (via STEAM) go in VR with Ctrl+Tab in the loby to choose A/D, plane, etc… but when the real thing start on runway, view blinks and game crashes.

I played on Wednesday night and everything was fine. Since then it’s been a complete mess. If it does work the frames are about 2 fps. No idea what’s causing this.

I have the same issue with the Rift S. Have you figured this out yet?

It’s not just Quest 2. I have HP Reverb G2 and I also have the same problem.

I have reset my quest 2 and it’s all the same… :disappointed_relieved:
I don’t know if it’ related but I have also noticed a bug in DCS World at the same time: when I get in the game, in the lobby and later in the game, my position is far above the normal position. And it’s impossible to reset position.

I have updated the quest 2 headset to the latest oculus beta firmware 28 but no luck, still same problem.