Quest 2 with NVIDIA RTX 3060 Ti - 5408x2736, 120Hz, 30 FPS

Hi all, after many days of trial and errors, reading/watching any guide/tutorial over the internet I finally reached a very good quality with NVIDIA RTX 3060 Ti GPU.

I don’t know if someone here is interested because I didn’t find any recent updated guide/thread with this GPU and this VR headset.

If someone is interested write here and I’ll prepare a detailed post!

EDIT, 7th November 2023

This guide describes how to configure the simulator in order to enjoy an excellent experience in VR mode with an NVIDIA RTX 3060 Ti video card coupled with the Quest 2 headset :wink:
With more powerful video cards, use this guide as a starting point by varying, for example, the “Pixels Per Display Override” parameter (increasing it) in the Oculus Debug Tool and “RENDER SCALING” (increasing it) in the VR graphics options of Flight Simulator, in addition to the other graphic parameters of the simulator.


NOTE: The “HOW TO START THE SIMULATOR” section explains the necessary sequence to follow each time to correctly start Flight Simulator in VR mode.


  1. Control Panel - Power Options
  2. Select the “High Performance” profile and press on “Change plan settings” to its right
  3. Tap on “Change advanced power settings”
  4. Expand USB settings and set “USB selective suspend setting” to Disabled
  5. Control Panel - Device Manager
  6. Expand Universal Serial Bus controllers
    • Right click on “Intel(R) USB 3.20 eXtensible Hos Controller - 1.20 (Microsoft)” - Properties
    • Go to the “Power Management” tab
    • Deselect “Allow the computer to turn off this device to save power”

### GAME MODE ###
Start - Settings - Gaming - Game Mode - On

Follow the screenshots:

Follow the screenshots then close the simulator:

Now configure the UserCfg. opt file, in the GamePass version of the simulator the file is located here:


where username must obviously be replaced with your Windows user. For other versions search on Google :wink:

Open the file and in the PostProcess section of GraphicsVR (not in the Graphics sectoin!!!) change the options as follows:

Note: after launching (or updating) Flight Simulator, ensure that these options were not changed.

### OCULUS applications ###
Oculus Debug Tool is installed together with Oculus and you can find it here:

C:\Program Files\Oculus\Support\oculus-diagnostics\OculusDebugTool.exe

Follow the screenshots:


On Windows registry modify/create this DWORD setting its value to 1:


Create a file named OculusMirror.bat with the following content:

start “” “C:\Program Files\Oculus\Support\oculus-diagnostics\OculusMirror.exe” --IncludeGuardian --IncludeNotifications --IncludeSystemGui --RightEyeOnly --Size 1280 720 --FovTanAngleMultiplier 0.75 0.75

In the application settings, deactivate the IN-GAME OVERLAY feature.

These options must be modified when simulator is in VR mode. VR mode must be restarted after that some options are changed so it is better to close and re-open the simulator and restart the headset. You can use OculusMirror.bat without put the Quest 2 on your head.

Follow the screenshots:


  1. To avoid problem, always disable Windows real-time virus protection
  2. Run Flight Simulator and set its process priority to High
  3. Run MSI Afterburner
  4. Turn on the Quest 2 then start Quest Link functionality on headset
    Optional : If you don’t want to wear it move the strap near the sensor between the two eyepieces and use the joysticks in front of Quest 2 cameras, then
  • Start SideQuest
  • Start streaming with ScrCpy function:
  • Click QUEST 2 CROP
  • “SideQuest Stream” window will be open
  • Start Quest Link functionality on headset
  • Close “SideQuest Stream” window
  1. Run Oculus Mirror.bat previously created
  2. Run Oculus Debug Tool and set the following values (also if already present):
  • Pixels Per Display Pixel Override : 1.3333
  • FOV-Tangent Multiplier : Horizontal 0.75, Vertical 0.75
  • (PC) Asynchronous Spacewarp : Disabled
  1. In Flight Simulator :
  • Press Ctrl+Tab to switch to VR mode
  • You should see 120 FPS on the Oculus Mirror window, if not check Oculus app again
  • Close Oculus Mirror
  1. Wait that Flight Simulator is stable at 30 FPS
  • Close SideQuest
  • Close MSI Afterburner


  1. To avoid problem, always disable Windows real-time virus protection
  2. Run Flight Simulator and set its process priority to High
  3. Turn on the Quest 2 then start Quest Link functionality on headset
  4. Run Oculus Debug Tool and set the following values (also if already present):
  • Pixels Per Display Pixel Override : 1.3333
  • FOV-Tangent Multiplier : Horizontal 0.75, Vertical 0.75
  • (PC) Asynchronous Spacewarp : Disabled
  1. Put the device on your head then, in Flight Simulator, press Ctrl+Tab to switch to VR mode
  2. Fly!


If performance will drop try these:

  1. Check that NVIDIA cache is disabled (should be with this guide!), if not clean and disable it
  2. Clean DirectX cache
  3. Perform End process tree of OVRServiceLauncher.exe from Task Manager, restart Oculus application and re-set Oculus Debug Tool options

If you have to swtich from VR to 2D mode press ESC in order to pause the simulator, press once the power button on Quest 2 in order to power-off the lenses, remove the device from your head and click Ctrl+Tab.

To re-enter VR mode put the device on your head, power-on the lenses then click Ctrl+Tab.



Quest 2 RTX3070TI Ryzen7 5800x3d give a solid 36-37FPS in VR
MSFS parameters on HIGH or ULTRA
Only one difficulty reading little letters MFD/PFD display TBM930 needing zoom

Yeah it depends on the airplane, e.g. Cessna Caravan is more difficult to read than PMDG 737-800, but also in the latter for some instruments a zoom is required.

If you want I can share all my settings in order to verify the differences from your configuration. The cockpit is good what I don’t understand is why I can’t reach the same quality for the outside like runway, buildings… In this case there is some blurry

Always welcome to share your settings.
Just received the quest 2 as a present.

1 Like

Yes please - All the guides I can find recently are all quite old. I have a 3070 but I think they are quite similar so should be helpful

1 Like

Updated opening post with all my settings and the startup sequence, let me know

1 Like

Excellent guide, thanks very much. I will certainly have a play :slight_smile:

1 Like

I modified some settings, I’ll update the guide for a 1:1 pixel image :wink:

Thanks for you work! I appreciate it!

But everyone wonders why VR isn’t catching on when you have to spend 5 hours adjusting settings to get it to run with a bit of performance. After work, the average consumer doesn’t feel like it. This is how the normal user would like it: switch on the VR headset like I switch on my Monitor, start Flight Sim, fly off. Reality: See above. Installing a Million Apps and tweaking a trillion settings. Microsoft isn’t a small software developer. They could automatically use the correct/best settings for the current system.
I didn’t fly in MSFS for weeks now because it’s just too stressful to set it up. Sometimes it’s super smooth in VR and sometimes I’m getting 2 FPS. With the same exact settings. Or after a while flying, it suddenly starts lagging. No idea. It’s just annoying.


I didn’t find the time to update the guide, as I wrote before I found a new configuration with better quality at 30 FPS.

I don’t know why this configuration doesn’t work well for you, what is your specs?

By the way there aren’t many options to configure before launch the simulator and maybe your problem is related to the fact that you switch between VR and 2D in the wrong way

GUIDE UPDATED, now we have 5408x2736, 120Hz, 30 FPS!

Enjoy :wink:

1 Like

Completely agree here. When I fly in VR now, it’s not about tweaking the setting to maximise frame rates, but not daring to take off the headset or temporarily drop out of VR only to have MSFS drop to 2 or 3 FPS when all systems performance figures show that the PC is having an easy time. 2 or 3 FPS in VR when the PC is at 25% CPU and 50% GPU looks so much more like a fundamental MSFS VR bug and not a question of tweaking setting to maximise the experience.


There is a bug somewhere, in order to exit VR and return to 2D (and viceversa) you have to follow the step at the end of the guide.

This guide is not for have higher FPS but to have a clear image reducing blur. 30 FPS is good, I don’t want 45 FPS with a bad image.

P.S.: sometimes when simulator performs at 2 FPS the only way to restore the performance is to restart the simulator

1 Like

Hey. It’s not about your guide. I’m sure your settings are tweaking as much performance as FS can deliver in VR and it’s playable. I’m stressed and angry about the general VR implementation in FS. When your flightsim is finally set up properly, it starts with performance problems after a while or when you take off your headset and so on.

What I want: Fly 1-2 trips in a relaxed manner after work. PC on, Headset on, go with the best possible performance on my PC.

What actually happens everytime: Tweaking, restarting the PC, restarting FS, throwing the headset out of the window, throwing the PC out of the window. And after 1 hour of trying and tweaking I’m finally able to fly… for about 30 min because the battery of the headset dies.

The result is, I’m not flying FS2020 anymore (an no, flat 2D is not an option).

1 Like

Exactly. It’s just no fun at the moment. Too much stress just to get some relaxing time with flying after work.

Yes I understood, unfortunately Quest Link is not stable as Virtual Desktop.

But with Quest Link the image quality is better.

I agree with you, MSFS VR implementation seems to be done by a kid, not by a professional developers