Quest 3 micro lag at terrain

Hi everyone, I’ve read a few topics but without much success. I’m trying to switch from g2 (since wmr will be eliminated) to quest 3 but unfortunately while taxiing on the ground at any airport, I see practically continuous micro jerks. the pc has a ryzen 9 7900x3d/4090/ddr5 32gb, I use a wifi6 modem provided by the telephone company, I have tried all the possible solutions but nothing changes. in particular I played a lot with VD and in particular with ASW which if activated is a little better but creates a lot of artefacts especially on PFDs, I raised and lowered the various bitrates, I installed oxr toolkit putting the override at 3856, set it to CAS, turbo mode. I tried removing v-sync, trying an external extender (but not wifi6), I should get a wifi6 router where I will only connect the quest, after which I’ve run out of ideas. but does this only happen to me? I thought I read that it got worse with the latest update but I’m not sure, other solutions?

1 Like

I have the impression that many of us are going through what you describe. I also switched from the G2 to the Quest3 and even after 2 months I still haven’t reached the end of my trial and error. I am also familiar with the micro-stutters you described. What surprises me is that the problem also occurs with a 4090 (3080 here). SU14 is suspected to have contributed to a deterioration.
All that’s missing now is a reference to MSFS 2024, which of course will improve everything from the ground up and the current picture of our journey is complete :slight_smile:

1 Like

Did you try to link the quest via USB?
I use quest 1. My experience is that it runs much better via cable compared to wifi5 (sight connection!). Wifi bandwidth is quite unstable here sometimes. The area where I live is very populated with wifi routers, so this might be different e.g. at the countryside.
Perhaps this situation might be the same with quest 3 because of the bigger amount of data to be streamed?
I’ve read that the quest 3’s battery power is somehow insufficient. So, with a USB cable you could stay longer up in the air. On the other hand, it might be a bit difficult to reach the toilet of an airliner :wink:

2 Likes

As far as I understand, there’s no getting out of this story :(, I still have the G2 with me and I’m really torn about what to do. These micro lags are nothing that makes the SIM unusable but I’m used to the fluidity of the G2, it’s really annoying I could try the cable but it is starting to become an unsustainable cost, however it must be taken into account that the G2 has its end of life unfortunately, other viewers such as Bigscreen have truly exaggerated prices.

I will just say, something that you might want to try before throwing the towel in… and something that pretty much solved things for me (Quest 3 also, but on 4080). You may have already done it but I didn’t see it mentioned so I hope it helps.

I was struggling with everything for far too long. Tried this and is much MUCH improved. Not perfect, but getting there.

Try using Riva Tuner to lock the frame rate directly on the FlightSimulator.exe to the desired frame rate (e.g. half your refresh Hz if you are using SSW).

Don’t ask me why, but VD itself was not really locking frames properly even though its fps counter suggested it was. It was not. Riva does and it really has smoothed things out for me. Before, my CPU was being totally hammered because there really was not a cap at the MSFS level, only after it sent it to the headset maybe. Really don’t know why but I can’t ignore that it was the case (should not have been but is!).

Of course you still need to balance all the other settings… basically don’t push it too much. Even when GPU Usage is nowhere near the limit (like around 50-60%) suggesting you can push it more, actually you can’t in my experience. There must be SOME things it struggles with processing when it has to do it for each eye at same time. I have not nailed down exactly what but I think it is a combination of the resolution and the supersampling. It just needs headroom I think.

Basically what I am saying is, set up Riva Tuner, lower all your settings just as a starting point test, lower LOD’s too and go from there to see if it solves the issue.

Also I discovered that every time you change any RESOLUTION related settings (DLSS quality or the High > Ultra > Godlike, or the OXRTK resolution) you NEED to QUIT and RESTART the VD app whilst you are in VR Mode otherwise it often struggles to recapture the correct frame timing (or something like that).

2 Likes

For me SU14 is the culprit. Before, it was smooth without VD or anything…
After SU14, I had to go from TAA to Dlss quality and from cable link to VD to smooth things to an acceptable level. (rtx 4090).

1 Like

Just to confirm Quest3 vs. G2 after SU14, also retry G2.

What has smoothed things out for me recently is to disable HAGS and Game Mode - 13700K and 4090 with Quest 3.

guys, thank you all for the support, I’m quite disheartened, I was hoping to move from g2 to quest 3 in view of the deprecation of wmr but there’s still a long way to go. in any case, for those who asked me to try g2 again, yes it is an option that I wanted to take, just to make a comparison. for those who advised me to lower the various settings, I tried but I swear nothing changes from lod 200 to 150 or ultra textures rather than high or medium to give some examples, I tried lowering everything but without great results. I have a doubt but I don’t know how much it can influence, my line has a bit high ping, around 29 but DL at 900mbps and UL at around 120.

I’m not a Quest 3 owner, but here is how I dealt with judders in VR (G2 in my case) with decent (and surprising) success. Use DX12 and clear all caches, both MSFS and DirectX. FPS limit MSFS to 1/2 your HMD’s refresh rate. Reset all MSFS VR graphics settings back to Default Settings, then slowly and methodically raise the settings to their desired values. Obviously if the judders are still present at the default settings it’s got to be a Quest issue. Also worth trying is MSFS’s Reprojection Mode set to Depth. If you’ve already tried all these things I do feel your frustration.

I’m surprised that the MS announcement on dropping WMR is being met with such urgency. As a G2 owner I’m waiting it out for at least a year or so. Can’t imagine that MS would go so far as to issue a specific future date, Nov. 1 2026, and then pull the plug on it considerably sooner.

Same specs here, run a quest Pro with the link cable. Super smooth. Had issues on win 11 did a reinstall an never better then before.
Operating system can cause a lot issues I noticed.

this are my debug settings.
80hz perfect 35/40 fps everywhere.
Good luck with finding a solution!!

from some of the tests that I have done, the only solution that seems to work is to set dlss to dlaa but with a problem, the fenix and pmdg pfds have that horrible trail effect on the altimeter, all the remaining tests don’t work. formatting the PC was done at least 20 times, the interesting thing is that the g2 in this respect is fine with the same settings.