Quest2 crashes to Oculus Home, Sim keeps running

I encountered an interesting issue before. I was for the first time trying to fly an A320 which went surprisingly well until about half into the 30 min flight (over fields and mountains, no urban area) when suddenly the Q2 crashed to Oculus home. I checked and the Sim was running - albeit stuttery but it recovered well - I tried to reconnect Link a few times until it worked again only to crash after 2min.

I use OTT with render scaling 1.3 and 30Hz ASW, in Oculus I run RS 1.1 on 72Hz (contradicting and I’m not quite sure what overwrites what).

BUT, when flying a prop over Manhattan with the same settings (mostly high, Lod 95, Scaling 100) everything is quite perfect.

HW: 3080, 5600x, 32Gb

Anyone ever seen that before?

So this has only happend to me in the last 5 hours.

On either airlink or oculus link the quest 2 is crashing all the way back to the quest 2 home screen.

Flew for a few ours this morning and had absolutely no problems.

No changes to PC that I can find.

I did a repair on oculus software, no difference.

This is happening for all games via link not just msfs.

Current versions of oculus

Quest 2: 28.0.0.221.359

Oculus software : 28.0.0.222.469

same here for the last day…

Ok,

So I tried a couple of things. I’m not saying that it’s oculus tray tools fault, but there was an update in the last 24 hrs, which I did install and update.

In the notes, Apollo has made a change to the quest link settings where you can manually set the bit rate. It defaults to like 300 if you choose the 2070 card option from the questlink menu.

So if you want to set it back to zero, you can. It may be (drawing a long bow here) that this setting back to zero doesn’t quite do the job.

So I tried a few things.

  • First restore defaults in OTT.
  • then uninstall
  • go into oculus debug tool and it may/should say 0. However, set it to 200 start up oculus software. Go back to oculus debug and set it back to 0.
  • for good measure also go back into the super sampling menu (oculus PC ) and reset your oculus quest 2, to 90hz and automatic scaling.
  • it will then restart
  • then test with link - check working and no crash
  • then test airlink - same as above.

I’m not saying it’s OTT, just in what I played around with of many things, this is what I did to get it working again.

Other things I noticed:
In quest 2 I was logged into my oculus account but not in my Facebook account, so logged in. Pure coincidence I’m sure but it shows 2 profiles now.

Also noticed that oculus had some services down today (came up in my notifications on oculus PC) and may also have been the problem and my changes may have just been coincidence.

Craig, if you can try what I have done, would be good to confirm and also if you have the very latest OTT installed that came out in the last 24hrs or so.

Let me know how you go either way

the first thing I noticed was my Rift S was working - when Q2 wouldn’t,

yes I did the W10 optional preview update & yes I updated the OTT,

will try out your suggestions…

Interesting, I did the update, too. I’ll try out your suggestions and report back later.

the new Oculus PTC update seems to have fixed things for the Q2 Link,

whilst still using the latest OTT, W10 optional update, & NVidia driver…

1 Like