Question: How to Setup SimToolKitPro?


How do i setup the SimToolKitPro?
It dosnt connect to the FS2020 although the right location of the sim is set.

Can someone help me?

thanks a lot

Have you downloaded simconnect?

FS2020 has own SimConnect and i have created the libraries ober STKP

I also had issues and gave up. I installed the sim connect server on my PC running FS2020 and the simtoolkitpro program on my laptop. Installed database under settings. Launched sinconnect server and see the gree box appear when FS2020 launches. I tried which by default is what Sim connect server populates the IP broadcast box to. simtoolkitpro doesn’t connect even though it says it does.

So then I tried populating the IP broadcast box with my laptops IP address and then tried to connect to MFS again on my laptop and again it says connected to sim but it isn’t. My firewall isn’t blocking anything.

This is a real pain so I gave up. Went back to FLTPlan Go which works so much more seemlesy and actually connects and shows my aircraft position on my phone. I’d recommend it if sinconnect is too much work for you to setup.


I gave up on this too. The app is running and connects with MSFS2020 as evidenced by the fact I get Landing Reports and Live Map tracking. BUT, no logbook entries. I’ve tried short flights and long flights and get nada for the logbook. Looks like I’ll stick with LttleNavMap.

1 Like

I recently installed this app and found the same, but I believe it’s because I did not add any aircraft to my fleet before I started.

Easy fix, right? Just add my aircraft! Well no, for GA aircraft it does not seem as simple as I expected. I was flying the C172 (steam gauges) which is not listed, so I gave up and flew without adding an aircraft. Tracking was OK and landing data was logged, but no hours or logbook entry.

I just got around to watching the provided quick-start video and it is covered. GA aircraft need a bit of a workaround by selecting ANY airframe type for now, as shown from the 2:20 mark in the video here:

I looked into adding my own custom aircraft for the C172 with steam gauges, as only the G1000 version and 172R are listed by default:

Despite those two entries having identical IDs, I could not create another as the field must be unique. Somewhat confusing…

For now it seems a little unintuitive here, so I’ll just come back to it later. I’m not doing many ‘serious’ flights in MSFS yet anyway, as the experience and immersion is a bit too inconsistent at the moment.