Radeon 7900 XTX reliable driver crash with MSFS and map apps?

So I got stupid and got a 7900 XTX which seems to perform very well, BUT.

But when MSFS has started to the main menu (running at a glorious 500 FPS, Asobo, fix that!) or I’ve loaded into a flight and then try to use Volanta or Navigraph Charts and zoom or drag the map, the driver reliably crashes after at most two seconds (tried both 23.2 versions including the one that was released last night). The same happens when I run the web versions of those applications in Firefox. The same does not happen when I use those apps besides other games, so far it appears that only MSFS triggers that particular case of AMD Kwality Drivers.

Does that happen for anyone else? Or do I have a personal weirdness?

Moved to Community Support-Tech Support for community assistance.

I have exactly the same problem. It always occurs when zooming a map, it doesn’t matter in which tool (Volanta, STKP, Navigraph). The current driver could not solve the problem either. The moment you zoom, the driver crashes and so does MSFS. The problem only occurs with DX11, with DX12 no problem. I also have a 7900XTX.

Having this issue as well. Have reported it to AMD multiple times, I recommend you do so each time it happens as well. I have found that it works with Skyvector no issue, but Volanta, Google Earth/Maps will reliably crash it. Hope to see this fixed soon.

I’ve put in a few reports.

Would be great if Asobo could fix some bugs in their D3D12 implementation too, if they could get that to render terrain properly and maybe not eat VRAM like candy, it’d be a nice workaround.