Reboot, Re-installation in Eternity

How to start MSFS 2020 after updating. I braught in august 2020 Flysim 2020 in MS Store to my new Desktop ( se spec. under my avatar). Win 10 Home was preinstalled. Flysim was running.
In sept. 2021 I updated to win 11 without any problems, flysim 2020 was running, no error message. Later I updated flysim to the ver. 1.22.2.0 witout any problems. Evry time I started Flysim it was from an icon on desktop screen.
3/2-2022 win 11 installed an update, an after this update I coudn’t start Flysim 2020. No error message, only a blue small ring on screen for 2-3 sec. (normally when a program strat to launch).
Then nothing happens, no error message no nothing.
Two times with online help an pc control from MS, taken hours without any result. MS looked aroung in PC an updated all programs, apps and drivers. Without any result. At last win 11 was reinstalled and updated. No results.
The next help was from Xbox, witch tells me to reinstall and update all apps. They tell me they don’t know anything about Desktop computers. (Same answer from MS about Xbox, they dont take care about PC’s.
All drivers and apps’s are updated, (xbox app reinstalled). Nvidia driver ver 511,79 for win 10-11. Community folder empty
Every one on MS forum, Zen-disk etc. just say re-install Flysim 2020 witout telling me how to clean up.
In my MS Store and Xbox app’s I can see I own this program. Wen it stop working I was not playing.
Is it really true, that nobody knows, where and how MS flysim license can bee controlled (could it bee in log-in script or some where in register database). I am online every time I try to log-in.

I have no clue about your problem and I own the steam version of the game… so I really have no knowlege about your problem or how to fix it.

My only thought is that you’re starting the game from a desktop shortcut. Could that be your problem? Maybe the shortcut is broken? Try this, right-click on the shortcut and select “open file location”. If the shortcut is working properly then a folder should open showing you where the original file is located. Make sure it’s the correct file to start the game. If the original folder doesn’t open then you found your problem. The shortcut doesn’t work. Then you have to find the “FlightSimulator.exe” file on your computer and make a new shortcut for your desktop.

Anyway, good luck.

It appears you have tried everything. If you have absolutely exhausted all ideas then its time to try other options.

  • Uninstall the game, run the Windows disk cleaners after that.
  • Now install the game under C:/MSFS or another drive like G:/MSFS.
  • Avoid the Program Files folder.

If the above does not work then, desperate measures (remember to back up important data first)

Do a FACTORY FRESH WINDOWS 10 install using the Windows Media Creation tool using a USB
https://www.microsoft.com/en-gb/software-download/windows10

Yes…Windows 10. But as stated above once all avenues are exhausted and you are desperate - its worth a try.

  1. Make sure its factory fresh, all partitions erased during the installation.
  2. Let Win10 update to the latest version, it will take repeated runs of Windows Update.
  3. Only once thats done and you’re on the latest version - now install the game.
  4. Again - remember to backup your data first.

Just my thoughts, I’m sure others will reply too. Good luck.

Thanks Mayhem. I have deleted the short cut from dektop and started from Xbox icon many times without any result. Someone in another thread has named it could be a problem in sky, witch only can be solved by an Xbox console. I don’t have this device.

It is recommended to delete the last system update

It would seem like a Windows issue in play here.
In this case, I would think your best bet is to correct that issue.
The best way to do that is to reset Windows.

First, uninstall the sim.
Delete all the remaining sim folders.
If you have addons you don’t want to loose, copy the Community Folder to somewhere outside the sim structure, such as your Documents folder, or preferably an external drive.
Next, reset your Windows 11 installation to factory specs.
To do that, go to “Settings”, “System”, “Recovery”, then “Reset PC”.
After that is finished re-install the sim.

Hi CDGO261
This is he first thing the remote helper from MS has done, before update. Then inproving update.

Hi Sevenflyer
First, flysim was not in play when this happened. As pointed out in another thread in forum, it about recognizing my approval after update. I really don’t want to reinstall. Everything else on my pc is functional.
If you are looking around in this forum you will found that I am not the only one with this problem.
As poinet out inthe Header line, I want a solid solution. What about the next update?.
This response doesn’t mean that I don’t want help

Happy days are back again (but for how long)?
As described in this threat I have tryed all advises. I refused to start all over again.
Yesterday I did it. Formatted my drive. Installed win 11 from scratch. Updated win11.
Installed all new intel drives with update. Ran a test. So far so good.
Then started to download msfs 2020 from ms store and xbox. This time it tooks me only 1 and a half hour.
Launching fly sim, evry things ok. ThenI connected my Honeycomb alfa and bravo. At last ruder kontrol.
Test fly, so far all ba ktl normal.

For my own happines i maked a full recovery disk (198 GB) included win 11
Thanks to all of you who tryed go help

1 Like

That’s great news. :+1:
Sometimes you have to “bite the bullet” and just do what must be done.

Best wishes !

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.