Recent update

Did the update from the MS Store. Restarted the sim and got to “press any key” and no key worked. Stuck right there. Fiddled around a while, then clicked left mouse button and that allowed the sim to continue starting. Sim started and I selected my home airport, as usual, and the 172 cold and dark. Now I find my keyboard and joystick bindings have all changed back to default (I think default) that I spent untold hours getting somewhat close to what I wanted.
Come on, Microsoft. I used to think you were better than that, but I’m having major doubts now.

If you have a recent backup of your C: drive, you can recover your bindings …

Go into MSFS and create an empty config for your controller.


Then go to

“C:\Users\ [YourID] \AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\SystemAppData\wgs”

and look though the recently created folders.

Within, you will find lots of folders. Sort by date to get the newest to the top.

Within each folder you will find a file with a huge random name

Drop it onto an editor (like Notepad++)

If its just garbage, close it and move to the next folder and so on.

Eventually you will come across a file that references your recently created config.

You then need to locate your backed up file for that controller (searching through in the same way)

Then copy and past everything between the “Device” Tags


and past into the new empty one, replacing anything that was between the “Device” tags

Save, and load the sim

MSFS should see that the file is newer than the copy on the cloud at it will be loaded and the cloud updated.

This is how I moved all my bindings from the Alpha to the release version without having to re-input everything.

Warning! Do this at your own risk. DO NOT ATTEMPT if you are unsure what you are doing.

Note: Every time you save a config, MSFS gives it a new GUID (random filename)

1 Like

Hopefully users don’t have to resort to xml coding everytime there’s an update. That’ll just drive people nuts.


I have the digital Microsoft Store version and I had no problem updating and lost no bindings (only flight stick and Pause On, Pause Off keys). The sim starts quite a bit faster for me after the update, too!

I just happy it’s reset the visuals from whatever the balls up Geforce Experience ‘optimisation’ made when I foolishly applied it. Joking aside though it does seem a bit zippier. Waited to install simconnect as per the known issues and it’s running nicely, even though I’m (knowingly) bottlenecking the CPU somewhat.

As someone else noted elsewhere, the tendency is to blame MS/Asobo ( never gets any credit! :slightly_smiling_face: ) for problems that arise, never one’s own computer or installation customizations. I’ve loaded previously existing .FLT files to spawn in mid-air and not had any problem yet with previously traveled routes.

@ JALxml

My bad, it’s related to a package I’m testing and the latest update has changed something on the configs it seems. Removed the package and all is back to normal.

I was thrown by the fact it was crashing with inbuilt aircraft, and didn’t make the connection to the package under testing. There must be some community package parsing going on at scene load to cause this, so educational.

That said, I have had quite a few CTD with the sim so far so it is quite twitchy. And that is on a clean install just flying around without undue stress on the system. Different contexts as well, sometimes scene load, sometimes in the middle of a flight maneuver etc.

I love the sim, but don’t get defensive about it. It’s complex, so it’s also buggy. And that is a MS/Asobo issue to address.

I think if you carefully read what I said, I’m just “matter-of-fact” and it’s someone else who’s yo-yoing around with feelings… I didn’t defend anything about the sim’s implementation. I only remarked that someone else observed that most people blame MS/Asobo for their problems but their own setups could also be a source, too. That’s facts, not emotions and not a defense of anything. Glad you found how to resolve your issues.

The fact is the sim is also quite buggy, and the tendency of some people is to be quite defensive about that. The SDK is also littered with undocumented TBD’s, so it’s in MS/Asobo’s interest to resolve that as quickly as possible so people don’t make packages that cause it to crash. Also knowing how files are parsed on load would be beneficial, as well as some kind of debug log utility to nail issues caused by that.

Thinking about it more, it’s actually pretty bad a failed package load causes the sim to crash. That’s not what we call graceful degradation. It should just ignore that package, log it out, and continue with the next.

1 Like

There was first a download from the Store, then there was an install inside the simm, mine went without a glitch. You have to give time to the updates to workout, look at the lights in your disk if is working, don’t hurry and start pressing keys.

Sorry that’s a cheap shot to blame users PC that run every other game on their drives other than this one
Oversights such as the developers not implementing DX12 on this title and the fact a patch to speed up loading times after only a few days smell of a rushed product

Agree with you …, as a Xbox user the smoothness of downloads on that MS platform are way better than this initial offering of FS2020 for PC and a PC user the download front needs a complete overhaul

So, I gave it a rest for a day since all my bindings disappeared. Fired up the sim this afternoon. Got to “Press Any Key” and I pressed a key and the sim started right up. Yesterday no key worked, only the left mouse button worked. So far, so good.
Started a flight in the 172 cold and dark from my home airport. And, boom…all my bindings are back just as they were before the update. Happy Days!
No idea what happened yesterday, but I’m back in the saddle today.

1 Like