Release: Working Title G1000 v0.3 - updated to v0.3.5 on 14 Apr!

I have the same issue. The G1000 screens are really dark and the dimming knobs do not work. Anyone else?

Scrolling to max does nothing.

Edit: I had to reload the mod and now everything works fine. So if anyone experience this issue then the solution is to remove the mod, run the sim and install the mod again.

Try scrolling to the top of this topic and use Ctrl+F to search. And I agree with you (and the other post I found in this thread) that VNAV would be an awsome addition.

1 Like

Had a complete PFD/MFD freeze today in the DA62.
Imported flightplan made with PFPX. Started the flight and added the approach (did not activate it). Got a direct from ATC (IVAO) to the IAF, and somehow then the MFD and PFD became unresponsive/ frozen.
I didn’t go offline though, but declared emergency and was vectored for a visual approach. Was fun and challenging to fly at night, in icing, full overcast and low cloud base on just the standby instruments and the whiskey compass.
Came down safely and walked away from it.
After switching everything off and on again, the PFD was normal, but the MFD still frozen.

1 Like

PLEASE Is there any instructions anywhere that tell you, line by line, word by word, on how to operate this blessed G1000? (And if I’ve missed something in the thread I apologise but I’m getting really frustrated)

I’m currently using the latest release in the Bonanza, as I’m tending to use it for my sightseeing trips. Flying VFR is no problem but I want to expand my experience so trying a bit of IFR and, perfectionist that I’d like to be, I want to use the G1000. Loading a flight plan inside the sim is no problem, even getting the STARs and SIDs to load, and so far the aircraft follows what I’ve planned. But when I get an instruction, such as, “Cleared direct to…” I can’t get it to respond to any inputs - in other words it doesn’t work!

So I’ve just spent a couple of hours “on the ground” trying to directly programme a simple flight plan. I’m following the official and very comprehensive Garmin G1000 “handbook” which I’ve downloaded from Garmin on the basis that it should be a reasonable facsimile of the in-game but I can’t even get a destination in, the FPS knob just doesn’t do what it’s supposed to.

From all I’ve read in this thread everyone seems to be singing it’s praises and that it operates as in TRW, but not for me so I’m obviously doing something wrong. I need a proper guide - I’ve looked at Utube but they simply just don’t cover it in any detail, probably quite rightly assuming you know what you’re doing.

Surely someone somewhere has produced an idiots guide - 'cos this idiot is getting real frustrated. Sorry if this sounds like a rant but @#~%"?+£<`!!!

1 Like

I don’t know which thread you have been reading? I don’t think much people claim the default G1000/3000 to be anywhere close to real world and its full of bugs. The working title guys are doing an incredible job improving the G1000/3000, it will get there eventually.

But as far as functionality goes, the FSX G1000 was more complete and less bugy compared to what we have now. At least you could make a flight plan in that thing and a simple direct to.

1 Like

This is based on the default, but this particular guide operates the same in the modded version, let me know if it still didn’t help.

Exactly what I’m looking for - just now starting the sim up to give it a try.

Thanks

Yay - it worked although I can’t see what I did any differently! Now to investigate some of the other functions!

I had the exact same thing happen tonight when I entered a direct to while on approach. Except in my case all the steam gauges froze as well for maybe 20 seconds. Then everything started working normally again.

1 Like

I fly the G1000 IRL and the one in game gets the job done.

3 Likes

Is this still accurate to the real-life G1000?

The pages are pretty much correct, but the usability is a little off.

Inputting text starts with letters and not numbers. the big and small FMS knob are swapped in a few places.

There is an official g1000 trainer. feel free to compare

For anyone finding that the brightness of the G1000 always starts on the minimum brightness on the DA40 or DA62 (or any G1000) aircraft. The issues appears to be related to the G1000 folder name. Rename the G1000 folder for any reason and the brightness always starts dim. Only an issue with version 0.3.4, as version 0.3.2 would allow you to rename the folder and still remember the brightness setting.

I’ve had the “G1000 dimmed bug” before, plus the “G1000 intensity” knob in the Carenado CT182T does not work with the G1000 mod. I’ve gotta make some tests to help the WT team troubleshoot this.

This goes against my understanding of how the Community folder works … Of course I’ve happened to been wrong before. :wink:

Hypothesis : isn’t what you see just a consequence that by renaming the folder, you’ve changed the alphabetical order of folders and now a mod that used to load before (/after) the G1000 mod is now loaded after (/before) ?

Good hypothesis, but not correct this time. My renaming convention always sees the working title mods including the G1000, load last. Using the original folder name does the same.

1 Like

Hypothesis #2 : the WT team left a full path (going up to the root dir) somewhere in a config file of the mod. I did a full search, this is not the case.

That’s what I thought might be the case too. Odd that you can’t find something like that then. I have logged the issue with the WT team.

Hey guys im still having this problem where if i try to put in certain waypoints or approaches the wtg1000 freezes on me, i wont have no map nor AI only synthetic vision, no speed nor altitude either. Is there a fix for this?

1 Like

Yeah still having the same issue. Only solution is to remove the mod and wait for an update unfortunately. Guess someday there will come a fix :slight_smile:

It feels like it’s been weeks since a WT update.

I wonder what they’re waiting for, and does it have anything to do with Sim Update 3 where MS-Asobo says they will address Gxxx issues?

Thank you so much for the work you’ve done on this mod. I’ve downloaded the zip file, how do I extract it properly into the simulator? I’ve worked with every version of MSFS and am familiar with adding aircraft, modifying panels, etc. For the life of me I can’t find where MSFS 2020 installed itself on my computer.