Removing TrackIR from the Controls Options

Had the same problem yesterday. Removing OpenTrack didn’t help. What worked was to disable all cameras. Click Start, search for camera, click Manage Cameras, disable any connected cameras. For me, it was the integrated camera on my laptop, which I’ve never used with OpenTrack.

I got the Revo uninstaller as suggested by Tobii and other comments and ran to fully remove some OpenTrack registry items. That finally got rid of TrackIR from MSFS.

Search for NaturalPoint in yoiur installed apps - that’s the driver underpinning TrackIR - and remove it. That may help

New Tobii user here. Just received mine in the mail and ran straight into the Tobii not working with MSFS issue (albeit working perfectly fine in general), apparently because additionally to Tobii there was still TrackIR recognized in the control settings (as mentioned by other users, MSFS has issues with both being present). For me that TrackIR entry was a “corpse” off an earlier attempt to use “OpenTrack” (didn’t work properly so I uninstalled it right away again months back).

Tip to anyone having the same issue - there is no need for elaborate resets or reinstalls of MSFS or Windows! Neither do you have to fumble around in your registry.

All I had to do was to install the newest version of OpenTrack (GitHub - opentrack/opentrack: Head tracking software for MS Windows, Linux, and Apple OSX), then right away uninstalling it again (might help if you use Revo or CCleaner instead of the standard Windows app center uninstall). That seemed to clear out those leftovers from my earlier use of the software. After a reboot and restart of MSFS, the TrackIR option in the MSFS controls menu was gone and Tobii worked straight away.

Maybe this might help somebody with similar issues.

1 Like

What make incredible an incredible solution is how easy it is, although working perfectly.

Can confirm that it worked for me, few minutes ago. A lot of time saved, thanks to you.
I hope it does the trick for others.

Thanks a lot for sharing that !
Cheers
K.

1 Like