Removing TrackIR from the Controls Options

I do NOT have a trackIR device connected to My computer. I am trying to get Tobii Eye Tracker 5 to work in the sim.

It works in their supplied app but not in the Flight Simulator.

One of the possible conflicts is another eye/head tracker.

My Control Options show a TrackIR.

How do I remove that from the Controls? It will not allow Me to delete it.

ETA: Oh, and I disconnected every device but the mouse from the computer and the TrackIR still shows!

I have TrackIR but do not have a control options listed for it in MSFS. Have you tried removing the tobi and seeing if the TrackIR option goes away?

Have you tried going to Windows devices to remove it there,?

Yes, it was there before I installed the Tobii.

I have gone to the device manager and there is no TrackIR there.

Even though you don’t use it, is the TrackIR app running (a little icon in your system tray)?

Also, look under your Add/Remove programs and see if TrackIR is listed there.

If it is, remove it.

Topic moved into #self-service:peripherals

I looked. It isn’t there. I can’t find trackIR anywhere except in the sim.

Could it be in your settings info that is “saved” to MS in your account? Don’t think I’ve expressed that properly but hope you get what I mean.

I am thinking of deleting my game account with Xbox and redoing it. But I don’t know if I can do that and not have to pay for FS2020 again. I’m having some real issues with the Store-bought FS2020 at the moment.

I at a loss then. I think I remember when MSFS was first released that TrackIR showed in my options under controls , but after an early update it stopped showing in there and I haven’t seen it in quite some time (still have and use TrackIR).

On my last flight TrackIR wouldn’t settle down or reset and eventually I couldn’t get any kind of proper view, even when closing the programme. I sorted it by going to the sim settings menu and switching TrackIR to off and immediately I was back to normal. I’m suspecting a USB issue so will investigate that and maybe reinstall TrackIR. Up to then it worked perfectly.
Incidentally I don’t think this control is specifically for the TrackIR addon as before I got hold of it I was using the freebie system, which worked but frankly was rough and that option was there in the settings.

Where are you seeing a setting to turn TrackIR on/off in MSFS?

Edit: Is it in the toolbar during flight?

Ok. Found the fix. Search your Microsoft apps and delete opentrack. That fixed it for me.

It’s in the Camera settings in General Options.

I don’t have opentrack on this system.

It looks like I will have to restore this computer and then try it to be sure that there isn’t some registry key hidden somewhere.

Did you check in your Microsoft apps? It was in mine from 4 years ago. Have no idea how it got there.

Moderators can close this thread.

Thank you everyone for taking the time out to reply.

I reset My computer to factory settings and then reinstalled Flight Sim. The Tobii eyetracker 5 is now working perfectly.

Again, thank you all.

Sorry that you had to go through all that, but glad you got it sorted.

I am having the same problem so hope this topic doesn’t get closed. There has to be a simpler solution than doing a full reinstall of FS.

I deleted OpenTrack from my PC but still have “TrackIR” showing up in Controller settings just like the OP said. Don’t have TrackIR app installed (have searched) and even did a Revo Uninstaller to get rid of some OpenTrack registry leftovers. Still no luck.
The best Tobii has offered so far is to edit the MSFS game config. No instructions on where to find that or how to do so, and it certainly doesn’t sound like something to try lightly.

1 Like