Render Scaling does not work!

Apologies, I’m running it at 1440p. If I had a 4k monitor, I would do.

Even a dirty-cheap Walmart 4K TV works great with MSFS.

1 Like

I run a 4K monitor with scaling set to 80. I set my rendering to 115 and ran it for little over 20 minutes to see if I could reproduce your issue. As of yet, I can not reproduce it.

1 Like

Thanks for trying man. I’ve found a few others on here with the same issue but it doesn’t appear to be widespread so it must be something wrong at my end. I’ve been troubleshooting it for 2 days now though with no joy.
Improved anti-aliasing from Asobo is the only answer I think.

Go to nvidia control panel and reset back to defaults if you haven’t already. I had problems with Ambient Occlusion. -Edit: Sorry I’m presuming you have an nvidia card.

1 Like

Here’s the bug thread about it:

Some say it disappeared when using an older nvidia driver.

1 Like

There are new Nvidia drivers, probably released three days ago 471.68, which could help.
But if others have the same problem, my money is on Asobo.
Overkill, discusses this problem in this video 12 mins in, I think he is not totally convinced its drivers so could still be Asobo.

2 Likes

I do have a nVidia card and I have already tried this. Sadly it hasn’t fixed it for me. I appreciate the suggestion though brother.

Seems that the temporary fix is to roll back my nVidia drivers to 466.77. I’m giving this a shot now and will report back after thorough testing.

Cheers all!

good luck dude!

1 Like

Let us know if it works,myself I rolled back to that driver version before and apparently it manages to fix some issues on my end.
Sometimes I wonder if updating the drivers it’s a good thing…

I never update drivers if everything is going fine, if you check the notes that are provided with the drivers you can guarantee there is never any mention of the flight sim since the Sim was released!

1 Like

What is the fps of your monitor? and any idea what fps your seeing when flying?
as I see in that 2nd screenshot that it’s hitting 112fps for that person, exceeding your fps of your monitor may cause display issue’s.

Only other idea is maybe your cpu or gpu can’t cope with 110 render scaling can’t draw all the pixels correctly or in time for each frame.

Rest assured that the people seeing these artifacts don’t have issues with their graphics cards. It’s the MSFS engine having some conflicts with the drivers in such situations.

Try different Nvidia drivers, i was having this issue with 471.41 so i rolled back to 466.77 and no longer have the issue.

Tend to agree with DORRAGER here… put a vsync frame rate cap of 60 FpS (Settings/General) and try again

Thats what I have. 3 of them actually. 43" 4k HDR set. Cost under $600. Don’t need more than 60hz so they work perfectly. Now in our living room we have a 55" LG C9 OLED. PS5 is hooked up to that for the kids.

1 Like

@CrustyPockets have you done a reset of your internet and checked the connection is good as well?

Ok so I’m 75% certain this could be related to MSI Afterburner or thermal throttling.

When I roll back to 466.77, the problem goes away. I can now comfortably fly around using render scaling 120 with no issues.
However I noticed my temps were starting to get higher than usual. When I checked my Afterburner settings, I saw that the ‘Priority’ feature was missing. Basically I have it set to a temp limit of 83 degrees, this way it throttles down nicely to maintain these temps. Any driver version after 466.77 has this priority feature.

Now I’m not 100% certain here because this issue appears to be affecting quite a few people more than I thought. But for now I’m going to have to stick to the current driver and just hope Asobo fix the AA or at least improve it.

The last thing I want is MSFS causing super high temps just so I can have some better aliasing.

1 Like

Those screenshots aren’t mine, I actually cap my frames to 60 already.
I think the link is MSI Afterburner.