Reverb G2 + 3080 = very disappointing performance. Something is not right

I have RTX3080 (EVGA FTW3), Ryzen 9 5900X, 64Gb of 3800Mhz RAM, 2 fast M2 SSDs, Reverb G2 - it’s a top of the line PC, it has to perform better than that! It’s borderline flyable in GA over sparse terrain, and unflyable in an airliner in a dense area.

I have waited for better drivers and performance to try again, and with latest Dev OpenXR I did. I got it to 22.5 fps and x4 motion reprojection. I guess it’s mostly smooth now in Cessna 152 lessons over sparse terrain. The problem it’s still not really good at all. In JFK landing challenge it dives below the smooth level and it’s all stuttery close to the ground. And very unstable - can crash VR when the new flight is selected, or get it to stuttery mess when it as OK just before.

I use all recommended settings - OXR 70 and tried TAA 80 to 100, medium-high VR settings in MSFS, tried all recommended sets. Tried HAGS on and off, all the rest of windows settings as recommended. Disabled virtual monitors in registry, set MSFS PC to full-screen lo-res 1080p (I have 4K monitor), disconnected 2 other monitors. Tried “official” overclock on 3080 and stable memory and CPu overclock. Created a .bat file to kill all unneeded processes and services when launching MSFS. Only launch after a fresh reboot. Other VR titles like Alyx just fly. Smooth and very high FPS. MSFS is a clumsy and uncertain borderline trainwreck… Sometimes (but not always) playable in GA. I tried MSFS VR first on a 3080 on 1.5 year old PC, and since upgraded almost everything - CPU, RAM, 360mm AIO liquid cooling, high airflow case, flashed the motherboard with fresh BIOS with USB fix.

What else could I try?

  • Latest Nvidia driver 466.27
  • Developer settings at preview On, scale at 70%, Reprojection Always On (Automatic was a mess). Runtime 106.2104.15001.0
  • WMR portal 2000.21041.1051.0
  • OpenXR 105.2104.13002.0
  • Latest Windows updates as of today, including the KB5001391 that supposed to have fixed stutters.

Very disappointed. Any advice about what else to try is much appreciated!

I assume you don’t have the steam version of MSFS otherwise I would suggest to try steam’s openxr. Also ensure you don’t have any additional super sampling going on with the nvidia control panel. Finally, if none of that helps, then set everything to low in MSFS and maybe 60% TAA. If that works then slowly increase the settings until it runs poorly again. I expect over time the game to get more optimized so just do the best you can until that happens. They want this to run on an xbox so they have to make it run better.

One last thought. What server do you connect to in MSFS? Maybe you have a server issue. Try others.

I have super smooth flight on a similar system but with i9 10900K and 3090 FTW Ultra Gaming as the differences.

Similar settings, but use 80 OXR Dev tools and 80 TAA in game with most settings on Medium, Low or Off aside from volumetric clouds which are on Ultra.

motion repro flips between /2 (flying high) /3 (most towns and airfields) and /4 (photgrammetry areas) but is always smooth and never below 22.5Mhz

Turning in game settings to high dips the refresh rate below 22.5hz and causes jutters.

All data is on 10.

@RomanDesign enter dev mod in FS2020 and enable the FPS Display. I assume that you have to less VRAM … VR enabled in dense area can fill my 6900 XT with 12 -14 Gbyte … try to precache the dense area you intend to fly to avoid any lack causes by (maybe to slow stream service)

What sort of performance are you getting when just playing normally on your monitor? I’ve got a 3080 and a 5600X. As with quite a lot of people the last few sim updates and Asobo ‘optimisations’ have killed my performance. Its next to useless in VR for me when before it was running great.

If you’re not getting really high FPS playing the sim normally you certainly won’t get great performance in VR and it’ll be a stuttery mess.

The latest sim updates particularly effected 3000 series cards by the looks of things. We just have to be patient and wait for Asobo to fix things.

You didn’t mention trying with motion reproduction disabled and WMR set to Best Visual Quality (Not Best performance) 90 Hz

I do have Steam version, but Steam OpenXR is a no-no with WMR G2, tried it once - it’s a slideshow. Have there been any changes lately?

Actually very good. Mostly 50+, in the worst places it can dip to 35 for a short time, but generally it fluctuates at 40+ to 60+ on 4K alnost everything on Ultra

Not good with disabled, very stuttery. I will try WMR Best Visual Qualiry setting now.

I’m using openxr via steamvr beta now rather than WMR’s openxr. Agree that it doesn’t perform as well but for me it’s more stable. I get CTD crashes using WMR but very little CTD’s using openxr via steam. For comparison, I run WMR at 70 and steam at 55. Steam is not as clear but it doesn’t CTD as much.

Anyway, it was only a suggestion to try it since you’re having trouble. And yes, it has been updated over these months and performs better than it did. Give it a try. It can’t hurt.

And I agree with @PostalMite89183 in that in the windows settings for WMR you need everything high. Then adjust in openxr and MSFS to get the performace you want.

I have not had any CTD’s using WMR with OXR since Microsoft applied a hot fix last weekend to their April monthly cumulative update.

I wish that was true for me but I still get them with my AMD 6900 xt. Only minor CTD’s using steam beta’s openxr. But @RomanDesign states he has poor performance so I only offered it as somthing else to try. It seems he tried almost everything else already so why not that too?

There’s been so many update’s and changes this last month I’ve had to re-tune almost daily. I’m running higher values than ever and that’s a big improvement since VR release back in Dec.

Tried it with OXR 80 / TAA 100 (I don’t like the stepladder effect on 80 that’s both a little bit blurry and jagged at the same time) and bumped all setting to Medium and Low (clouds Ultra) like you suggested. Based on other guides I didn’t expect I need to set it so low on a top of the line GPU (well, other than your 8090 but that’s really an overkill buck-to-performance wise for me). Guess what? I’ve done several landing challenges and they were flyable. Smooth for the most part, and sufficiently sharp. Some stutter occasionally when I turn my head fast, but not too much. Most head turns are smooth.

You cured my depression at least :slight_smile: This is by far not the perfect performance at all. But if you with 3090 have to set it so low, and I’m about 14% behind with my 3080, it is what it is. Still looks gorgeous, compared to X-Plane.

I also found an app called SkySpaces and replaced my WMR cliffhouse with an empty roon, to save some VRAM and resources.

MSFS has a long way to go performance-wise, in VR, it shouldn’t be so bad, but it is… It shouldn’t be much worse than 4K, but it’s so much worse. I can run 4K at 50+ FPS on Ultra, easy. Also, using mouse instead of controllers is horrible, just horrible, but Asobo is working on that. Well, Jorg from Asobo says he uses MSFS exclusively in VR, so he must know the issues. Let’s hope it gets better soon.

I’m enjoying fabulous performance, in that my flights are very smooth. Don’t check my frames. I run Ultra settings when flying on the monitor in 4K and Ultra settings when flying in VR with the G2.

I9 10900k (not overclocked), 64gig RAM, 3090 GPU, running on an M.2 drive, 30mbs link.

I should add: Provided not in multiplayer with non-standard liveries being used by other players.

2070 super, i5 9600k 5ghz. 32gb ram.

Oxr 60/70 taa 70

Mostly everything low, trees high. Tlod and olod 100

I have to fly simple none glass aircraft away from photogrametry to get 22.5 stable for motion projection.

Today I was able to get the tbm working with motion projection. I noticed it bounced between 22.5/30. With live weather and lots of clouds. But prior to that I was seeing 15fps in the cub with clear skies. It’s maddening.

The sim has such a massive performance envelope and you never know what you’re gonna get.

It’s so strange… What I am seeing (not just in my case) that some people with 3090 only have decent performance with mid/low settings, and others have great performance with lower cards, or in your case the same card. I have no explanation for this. I’m trying to figure out what is the difference, and I don’t see one. It’s like it’s random… Our GPUs (3080 and 3090) are within 14% performance-wise, and many people with 3070 and 2080ti claim better performance than what I’m having (so it’s not VRAM amount that does it). Our CPUs are also within 1% performance difference. It doesn’t make any sense that you are having good performance in Ultra settings and I’m barely having adequate one in mid/low settings. So strange… Good for you, I mean, but I have no explanation for this…

Agree. Mind you, I mainly fly GA aircraft. The most sophisticated being the Working Title CJ4.

As I said, I haven’t got a clue what my frames are but as long as I have smooth flight, I don’t really care. Good visuals, sharp image and smooth performance - perfect trifecta.

I don’t have CJ4 but I bet it’s just as complicated and resource-hungry as stock airlner, probably more. And yes, I do’t care about FPS too, as log as it’s smooth and fluid. It’s just a metric to compare to some degree. I disabled the counter now that I know how it “feels” when there’s not enough FPS.

Couple of other nasty bugs I have as well:

  • If for any reason MSFS throws me out of VR - I can’t get back in. My monitor shows it’s in VR mode, but G2 is in the cliffhouse, with no way back.
  • If I do a landing challenge, and then click “next challenge” after loading it will always throw me to the cliffhouse again. MSFS is still there, but VR is locked out. Every single time. But if I go back to “Activities” screen and select the next challenge manually, it works OK
  • If I go to GA lesson in Cessna 152, and enable VR after I click “ready to fly” - controls are not responsive, yoke/pedals are not working at all. If I go to “opptions/controls: a see all axes moving OK”, but inside the lesson - nothing. It may be so not just in lessons, but I started engaging VR before I actually start loading the flight, so I don’t know.
  • One lesson (First Solo) has Cessna rolling slowly backwards on full throttle. Brakes don’t stop it, it just keeps rolling backwards very slowly on any throttle position, so obviously I can’t take off. So weird.

Regarding the issues with the G2 stuck in the Cliff House, I find it is important to ensure the mode your G2 is in is correct. You will see a notation to press Win Key + Y to set the control back to the sim (also ensure you have the sim as the application of focus). Then press the key combination you use to switch into VR. Worst case, terminate the Mixed Reality Portal, reload it and then reconnect to the sim.

I’m wondering if it isn’t a issue with forcing windows OXR on a steam version MSFS. I’m using the store version without issues. You steam version users might clarify.