Reverb G2 not working in WMR

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting. Not the issue

Are you using Developer Mode or made changes in it? No

2 Videos displaying the issue: Videos too large

Provide Screenshot(s)/video(s) of the issue encountered: All was working fine, then tried working with OpenVR app and ever since FS 2020 will not work in VR. Windows Mix Reality and MSFS work fine separately. When I toggle to VR in the sim, the VR starts displaying the sim then it goes back to WMR. It then continues try to display the sim endlessly. On the #1 monitor, it displays WMR with FS2020 problem.jpg flickering and in VR it displays a repeating of the transition burst.

Detail steps to reproduce the issue encountered: Toggle the VR mode

PC specs for those who want to assist (if not entered in your profile) Operating System
Windows 10 Pro 64-bit
AMD Ryzen 7
Acer ET430K (3840x2160@60Hz)
Generic PnP Monitor (3840x2160@60Hz)
S27C750 (1920x1080@60Hz)
Generic PnP Monitor (1920x1080@60Hz)
931GB Western Digital WDC WD1002FAEX-00Z3A0 (SATA ) 35 °C
465GB Samsung SSD 850 EVO 500GB (SATA (SSD)) 32 °C
3726GB Seagate ST4000DM005-2DP166 (SATA ) 29 °C
7452GB Western Digital WDC WD8003FFBX-68B9AN0 (SATA ) 36 °C
1863GB Seagate ST2000DM001-1ER164 (SATA ) 32 °C
1863GB Seagate Backup+ Desk USB Device (USB (SATA) ) 39 °C
931GB Western Digital WD 10EADS External USB Device (USB (SATA) ) 35 °C
Optical Drives
Realtek High Definition Audio

`Did you submit this to Zendesk? If so, what is your ticket #97561

I too have a similar problem
After the hotfix, I find I am unable to activate Vr at some airports.

I have the HP G2. using 2080 Super.

I set up a flight. load sitting in cockpit cold and dark. I then activate VR using default keys.

Now at some airports KSEA, for example, instead of finding myself seeing the instruction to press key to set vr view. I either have a black screen or about 4 white dots moving around each other. and that dance never stops. Meanwhile, on the 2d monitor I can see that VR is active waiting for cockpit view to be set. Pressing the space bar to set the view does nothing.

Attempting to disable VR mode sometimes takes me back to the 2d view, but with badly degraded performance. Sometimes I cannot get back to 2d mode and I just have to use task manager to kill MSFS.

If I activate VR at the welcome screen, all is well till I am waiting for the flight to load. I can see the blue bar till its about 60% done, then my VR screen goes black and on the 2d monitor I can see the progress bar is just sitting there. …I then resort to task manager as nothing MSFS related responds anymore.

I have restored to VR default settings, reinstalled mixed reality, openXr, I have rolled back Nvidia drivers, I have changed USB ports, nothing helps.

On the few occasions that I am able to get Vr activated at these airports, performance is normal.
Zendesk ticket #100134

Any advice appreciated.

OK Reverb G2 users, I spent the last three weeks trying to have VR working. Nothing worked till now. The last thing I wanted to do is what worked. Uninstall MSFS2020 and reinstall from scratch. Reset everything. But it works!


As I have said in other topics, this may be related to a game window (like ATC) opened in a second monitor when you launch the VR. Try to start a flight with no VR, remove all windows in separate monitors, and start VR.

I resolved the issue which was a problem with addons in my community directory.

Thanks for the fix and back to flying in VR again!