Rift S - flashing white light

Good luck with that! Oculus support is the pits.

Im crying inside as I cannot enjoy MSFS2020 until this gets fixed, I like to try Virtual desktop, but I dont want to be forced into buying the programme. I wish Oculus firmware update was not automatic, it auto downloads when you start the Oculus app and installs itself… I might have to give in and reset up my Valve index which has noticeable screen door effect.

does Asbo now this issue with Oculus users? I could not see it in the issues raised page…

I must say I can turn the flash on and off at will. Not sure whats different about my set up but its totally playable. I get the flash maybe once a minute or so, nothing more.

I suspect i am not alone in submitting a zendesk ticket on this and i have received a couple of responses suggesting that they are investigating, but whether Asobo have registered it as a priority will probably depend upon how many they have received.

Therefore, for anyone suffering this issue, if you have yet to submit a zendesk ticket, then now might be a good time to do so.

I made this video (posted on private list, not public) just few minutes ago to show the current state on my machine. This is using last NVidia driver 461.71, but I tried also with 457.30, and last Oculus driver 26.1.0.41.502).

I tried and have to lower my fps to 30 to get it less often, I guess 18 will be also better. But NO! I want my fps at the maximum, this need to be fixed as it’s not acceptable at all.

Edit : posted also on Oculus forum

2 Likes

Oh man thats unplayable.

Have you linked that to your zendesk/oculus tickets?

Have you tried uninstalling the existing oculus app and reinstalling the normal version downloaded from their website?
Simply unchecking public test channel may not remove all beta settings…
Once I had audio stuttering issue with the beta version and solved that problem by doing above reinstalling work after finding only unchecking was not sufficient.

We cannot fix this problem by removing the beta setting anymore or reinstalling (or repairing) Oculus Software. As I said, now Oculus released the final version v26.x of their software. The beta was in between release v25.x and v26.x, so unchecking beta allowed us to return to stable v25.x. It’s over now.

1 Like

I didn’t make yet a Zendesk ticket about this specific issue for now. I know some of us already did, but I definitively do one too to put some pressure and make things move.

1 Like

Did they release the new version? Mine is still v25 and no symptom of update yet. Have you certainly unchecked, uninstalled and reinstalled it?

Yes they released v26.x but you know they use a rolling system for updating people, and from the very first day (5 or 6 years ago?) I’m one of the lucky guys receiving the release on first minutes they post it. It can took more than 10 days for everybody to be served AFAIK.

Thanks for info. Have to wait my turn to see it ruin stability…

The answer to my ticket from oculus sopport…

Thank you for reaching out to Oculus Support. I understand that you’re experiencing black screen and flashing lights with your Rift S. I will be happy to look into this for you.

To begin, please disconnect and reconnect your Rift S from your computer with these specific steps:

1. Unplug the USB cable from your computer.
2. Unplug the mini DisplayPort or DisplayPort cable from your computer.
3. Wait 10 seconds.
4. Re-plug your USB cable into your computer.
5. Wait 10 seconds.
6. Re-plug your mini DisplayPort or Displayport cable into your computer.
7. Your headset should receive a firmware update. Allow this update to proceed.
8. Check to see if the DisplayPort is detected and there is an image in the headset

(On a separate note, please check your cable and cable connectors as well as ports for any signs of physical damage. If you see anything that could be physical damage, please send us pictures of it and we’ll be happy to check them for you.)

When you have completed the above, please manually install the latest Oculus drivers:

1. Close the Oculus app.
2. Press the Windows key + R on your keyboard to open the Run command.
3. Enter C:\Program Files\Oculus\Support\oculus-drivers.
4. Open oculus-driver.
5. Open the Oculus app and then try to connect your headset again.

If the issue still persists after completing all those steps, please continue below to review other potential causes for this issue.

ADAPTERS/EXTENDERS

Though they are unsupported, some adapters and extenders can work fine with our headsets, but not all are guaranteed to work. The only fully supported adapter is the mini-DisplayPort adapter which we include with the Rift S.

If you are using any type of additions to the cord connection between your Rift S and your PC, such as adapters, extenders, or hubs, then please remove them all and plug your Rift S cables into your PC directly.

For reference, please check our support page article here.

DEDICATED AND INTEGRATED GRAPHICS CARDS

Many motherboards have graphics cards built into them. These are known as “integrated” graphics cards. Conventional graphics cards that are their own component in a PC are known as “dedicated” graphics cards.

The Rift S is not supported to work on any integrated graphics card. It must be plugged into the dedicated graphics card.

Additionally, the Rift S works in tandem with the secondary display, the computer monitor. Please make sure that both your Rift S and your monitor are plugged into the dedicated graphics card together.

MULTIPLE GRAPHICS CARDS

Though some configurations can work, the Rift S does not support the use of multiple dedicated graphics cards.

If you have a CrossFire or an SLI configuration, please physically uninstall one of your cards.

UNSUPPORTED DISPLAYS

The Rift S is designed to work in tandem with computer monitors. Though some TV’s may work, they are not a supported form of a secondary display for the Rift S.

If you’re using a TV, tablet, projector, or any other type of display, we’d ask that you remove it and connect a computer monitor instead, to ensure that you’re using a supported secondary display.

MULTIPLE DISPLAYS

Though some of these configurations can work, the Rift S can potentially experience issues if more than one secondary display is connected.

The only fully supported configuration is to have the headset and one monitor plugged in. If you are using 2 or more monitors or displays of any kind, please unplug the extras.

USB POWER/BANDWIDTH ISSUES

The Rift S does use USB power and bandwidth from your PC. If your PC’s USB is being worked to capacity, this can potentially cause the kind of issue that you’ve described. To help check if this is happening, please try the following:

** Unplug all USB devices from your computer except for your keyboard, mouse, and Rift S.*
** Plug your Rift S USB cable in to the back of your PC, not the front or anywhere else.*
** Disable USB Selective Suspend Setting:*

    1. Right-click Start.*
    1. Click Power Options.*
    1. Click Additional Power Settings.*
    1. Click Change plan settings.*
    1. Click Change Advanced Power Settings.*
    1. Find USB Settings.*
    1. Make sure that Selective Suspend Setting is set to Disabled, not Enabled.*
      ** Ensure that USB power saving settings in Windows Device Manager are not enabled for your USB ports:*
    1. Right-click the Start button and open Device Manager.*
    1. Find your USB ports.*
    1. Right-click and select Properties.*
    1. Go to Power Management.*
    1. Make sure that options to save power are deselected (please note that it is normal that some of them will not have any checkbox for power saving settings).*

Once all that has been confirmed, please restart your computer.

If you have confirmed that the potential cause of issues mentioned above do not apply to your configuration, please send us a copy of your Oculus Logs for review. In order to do this, please note the following:

** Make sure that your Rift S is plugged in to your PC while you collect the logs.*
** Do not check the Auto submit option as this will not save your logs on your computer.*
** Make sure that the Full logs option is checked.*
** Choose 1 Day of logs, even if your Rift S was not used in the last 24 hours.*

For steps on how to retrieve the logs, please click here and refer to the second section titled: ” If you’re experiencing issues while using Oculus Rift S or Rift, collect logs from Oculus Diagnostics:

Once complete, a .zip file of your logs will be saved to your Desktop, its name will usually start with: ” OCULUS_LOGS… ”. Please send the entire .zip file as an attachment to us without modifying or removing any of the content inside.

If the issue still persists, please let us know and confirm for us that you’ve checked everything we mentioned above when you send your logs in.

About Onward app, it is coming soon for Quest, you check this link click here but we don’t have details if they can play with people on Rift.

Please let me know if the steps above will work for you or if you need further assistance.

This is unfortunately the copy/paste response they send in any case even if you contact them for a scratched lens…No hope here.
They really need to investigate and I trust the Oculus and MSFS Devs for finding a reason if this problem finds a breach in their support wall and reaches their desk.

1 Like

I noticed with me, it will only do it in the cockpit. When its glitching ill switch to external and see my plane flicker then it will stop. Seems only to be in the cockpit for me. It is rather annoying. I just got my Oculus up and running, having to figure out i need to stop my antivirus while using and now its not even playable! Hope its fixed soon!

Well, it was awful for me, so I unticked the beta option and it seemed better for a whole day. Still flashing, but only once per minute(ish). And I could live with that. Fired it up again this afternoon, and it has reverted back to being awful again, flashing every couple of seconds or so. Even flashes in the menus. Not happy.

So is this the pure white light flash or does picture change.
I just created a post where my view flashes/flickers, but its not a white flash, I can actually see a different picture for the fraction of a second, as if the camera is being moved/rotated to some kind of default pose and then returns back to my head’s tracking. I’m wondering if this white flash is something similar. I don’t think I’ve noticed it on my CV1 before, but I did notice some gauges flashing from time to time.

Same issue here. I kindof saw this coming, because sooner or later Oculus is going to make their betas the regular version of their software. I tried enabling the beta thing again to see if there’s a beta version which performs better, but no juice.

I guess we’ll have to inundate the peeps over at Oculus to make them look into this. What a sad state of affairs… the main reason I got MSFS is to play it in VR in the first place. let’s hope this gets resolved soon, somehow.