Runway Tears / Terrain Issues in Photogrammetry Areas

I can also confirm the bug is still around. Tried it with both the Asobo Deluxe and FSDT KORD versions. As others have noted, this appears to be due to LOD issues with the terrain meshes. If I leave the drone cam around for a moment, the entire length of the runway will be smooth. If I move the drone cam away to reduce the LOD and then quickly fly back over the runway, the tears come back.

These tears are not specific to runways either. It’s hard to see these tears with things like trees and grass in the way, so I found a rural road and flew the drone cam over at high speeds. The very same tears were present there too.

Still an issue after the most recent update.

Yes, seen this also in Rennes airport LFRN.
Same problem as seen 3 months ago.

Having previously experienced this issue is previous ‘free flights’ at various photogrammetry airports around the world I have now started to see this in a landing challenge!

I only have just got around to trying the landing challenge in Southampton (whose photogrammetry only recently got re-enabled after the WU3 launch, I believe).

For me it is impossible to complete this landing challenge due to the runway tear issue on landing.

1 Like

I just flew my first flight with the most recent 9+GB patch (sim update 3) and it seems the runway tears are back. I haven’t had this issue since my mention of it a few months back.

It’s all part of the same problems, runway tears, draw distance, stuttering, low fps. Somehow the game now tends to fall behind updating the terrain ahead. Something about the way terrain is loaded in and processed goes wrong, causing fps drops, stutters, and terrain not being updated in time.

Runway tears are a mismatch between different versions of the tiles. One tile is already at max detail while an adjoining tile is still at a lower detail.

Reducing draw distance mitigates the problem somewhat. I reduced terrain detail from 200 to 100, and although I still get horrible stuttering now and then over areas with lots of trees, at least it doesn’t get so bad anymore that whole tiles of ground underneath me are still bare low res sat detail.


Very glad I’ve found this post. I’ve hit the runway tears on KSEA 16R a couple of weeks ago, and then KMSP 12R tonight. Very frustrating, especially after a multi-hour flight.

1 Like

Instead of flying straight in, you could circle the pattern before landing to give the sim time to get everything loaded in. Or simply pause before landing until it’s done loading in the scenery.

I had another bizarre bug pop up again after a long flight over ocean on auto pilot. It seems the game ‘forgets’ about the plane functionality. (I’ve had it happen before) All the plane animations were gone, buttons, levers, flaps, landing gears, pilots, all gone. I landed my ghost plane hoping the landing gear had actually deployed (neither the gear nor the confirmation lights were showing). It worked and showed my plane hovering above the runway without any wheels and no flaps. The game only had 15GB allocated at the time, 3.5GB active memory, ‘airport’ was just a field of grass (bad data in the area). Only restarting the game fixed it although I could have tried reloading the plane in dev mode. At least there were no tears in the empty field!

Yep, I’ve seen screens and buttons disappear too. I once thought this was due to overclocking an older GPU (RX 580), but a newer one (RX 6800) has done the same thing a couple times without overclocking. I’m thinking I’ll probably do the pause trick maybe in the last 1000 ft of altitude to see if that gives the game enough time to load everything for the runway.

Just encountered it at KCYS after the performance update.

1 Like

… while this might help “a little” I can not confirm that the “loading” part is relevant to the issue.

With my “crazy-zig-zag-drone move test” I can see that moving rapidly up and down the runway will constantly generate tile cracks at different places. It is not (really) about “loading from the Azure servers” … in my case everything is clearly cached on my machine … but the problem is the progressive LOD refinement of the visible 3D (GPU) data which gets extracted from the real 3D (world) data.

I think the best “hack” so far for real landing is to press “pause” shortly prior to touch down … wait 10 to 30 seconds for the cracks right in front of the aircraft to “heal” … and then un-pause again.

1 Like

I’ve never tried that. So you can generate them on demand with the drone, presumably set to its fastest speed?

I’ve never seen these runway cracks. I think I have seen some other anomalies at a handful of airports, where parts are elevated for some reason, bumpy taxiways, and the like.

So if I wanted to test this I could spawn at any airport, on the ramp, then fire up the drone to start flying around, and generate them?


I place the drone on the runway. Set seep to max. Then zip back and worth over the airport (runway) and so far it was always possible to continuously produce “unlimited” tile cracks in constantly changing locations on the same runway. The “best” part is, that you can stop the drone instantaneously … and watch how a (set of) tile crack(s) will heal.

My “test location” is KBFI … but it should work everywhere, where the airport is in a photogrammetry region. It seems like those areas are “tile” based … while the other regions are “mesh” based.

Here is one example image from KBFI:

But in general those cracks are not limited to the runways … I was able to “crack” regular city scenery in the same way … but that is less visible and not critical for the aircraft (flight experience)

1 Like

I tried but couldn’t make it occur. I did see something in the river nearby, but they don’t auto-heal, and only come, and go based on my proximity. The runway, and ramp showed none of those artifacts.

Orlando, Taxi way j to 36 R aircraft fell into hole up to fuselage. Also auto traffic from below taxi way driving across taxi way ?

Landing Ktpa runway 1L aircraft hit something causing a crash?

What frame rates does your setup achieve?

I run on Ultra-4K (AMD Radeon Vega II - 16 GB) … and barely exceed 15-18 FPS
It could be that “healing” (progressive refinement) is linked to FPS. Like every frame is allowed to update n% of the data.

Besides that my drone-zig-zag-test is less “predictable”. I often stop … move backward … than sideways … than forward again. Perhaps this is “tripping” the internal geometry prefetching algorithm.

And “yes” … cracks in water seem to be different. I suspect they are more related to the problems of “flattening” a “non-flat” surface. Water cracks typically do not heal in my case … they just “morph” into different crack or they stay around.

I didn’t have it open, but I would imagine the 40’s. It was quite smooth.

My first thought would have been an internet speed issue, which might explain the initial approach, but is not explained by their creation while moving around in the same area repeatedly.

Perhaps there is something else at work which explains why I have never seen those runway tears. Who knows.

It’s the updating process. I can reproduce it there as well by leaving the drone on the runway, go fly and switch back to the drone. Then you see it loading in from ground zero (instant teleport back)

My FPS is limited to 20 (in the settings) and in PG closer to 15 fps. It generally keeps up while flying around PG areas but instant teleportation takes a while for scenery to complete. Here well over a minute. The runway tears appear just after the 1 minute mark when it starts refining to high detail.

My settings are on high, terrain detail 100, object detail 150, 1080p, render scale 150 (CPU limited 2.2 ghz)

Btw on repeat tests, the order things get loaded in and updated is always slightly different. Sometimes the tears last longer, sometimes they are pretty much skipped over instantly. It’s definitely the transition from the full runway getting replaced by photogrammetry pieces in the final high detail refining stage.

High end machine, 4.2 GHz 65Gig , RTX 3090 no jitters at Max settings. Also noticed latest update, flight sim looses focus on flight director? Aircraft breaks off heading and rolls! Have to manually recover. Looks like to me PC gets busy somewhere almost like focus moved to another display? Eventually citation longitude regains reality!

Wonder if sim software gets busy somewhere loading, updates from Flight Director, variable data lost, etc. I do know it is getting lost because response from atc stops updating for a period of time!