Saitek flight control issues since Sim Update 4

I downloaded the new update. And since then. My flight controls….yoke, throttle and rudder pedals do not work. Or they work then stop working. Never had this issue before the update. It also makes keys on the keyboard not work too. Any fix or anyone having same issue?


okay - updates should not cause these failures. Unplug and then plug in your ‘Yoke’, pedals, and keyboard without having MSFS running - just after booting your PC - then check to make sure they are installed and calibrated (that your PC ‘sees’ them)
Then open MSFS and open the ‘sensitivity’ settings for your controllers. Yoke, Pedals, KB, and just make sure they register - then set to ‘default’

** have you noticed when those things FAIL in the simulator - is it when you have the ATC window OPEN?? have you just entered a response to ATC and closed it - then noticed your controllers have no connection to the sim (stop working?)

I keep atc window open at all times. At the start of the flight everything works. Then after a few minutes. Nothing. No response.

It doesn’t seem to happen to smaller planes. Just 787, 747. Could it be I have too many USB’s plugged in?

I don’t know - I almost ever fly the tubes myself but it shouldn’t matter what you’re flying

whenever you post a problem like this, you need to post A WHOLE LOT MORE information. Nobody could ever understand your problem from what you posted.

  1. What hardware yoke and pedals and throttle are you using?
  2. Are you plugging your hardware into a USB hub (either external or an internal USB hub in your computer)? This is a no-no and just asking for trouble. ESPECIALLY if it’s an unpowered USB hub. I plug CH Products Throttle quadrant into a powered USB hub, and it constantly gets disconnected, though, usually only at start up. The fix that works 98% of the time is to unplug it and plug it back in.
  3. How exactly are you experiencing the disconnects? What plane(s) are you flying? Anything in your Community folder?
  4. Where are you flying?
  5. When does it occur? your first post is very different in explanation than the next post.
  6. Have you tried unplugging and plugging them back in again?

USB is pretty much the wild west of component architectures. There are differences across the board from all manufacturers in how they implement their USB hardware. As I noted above, if you’re plugged into an unpowered hub, you’re just asking for trouble, as the devices likely are getting starved of power. You might also have driver or, we rarely hear much about this these days, but, it’s not impossible, even interrupt processing issues (irq) depending on your setup.

I don’t know how to do it, but figuring out how to get a log saved to disk of services might help debug the issue.

If it’s CH Products, there is a driver program out there (I forget the name), that some people swear by. But I think it was written for XP. I tried it and had lots of problems, and removed it (which caused problems in itself)(basically, you have to make sure the program is started when the computer is booted or you’ll have issues, I didn’t feel like going through that process).

(Could you please edit the title, it’s killing me :wink: ) :fried_egg:

Ok here goes.

Yolk, pedals, throttle quadrant is Saitek.

I plug straight into PC.

Mainly occurs on the bigger planes. 787/747

Everything starts fine. I move yolk and I can see it move in plane. Once atc clear me to go. It stops altogether. Won’t let me adjust my height on the keyboard either. Up/down/left/right keys do not work. Escape button does work funny enough.

In smaller planes I have not seen an issue.

I have changed the title for you.

I have a pretty new PC. Never had any of these issues until I updated the other day.

(I feel bad saying anything… It’s Yoke, not yolk. Yolks are in eggs)

Sorry, I don’t have any experience with Saitek equipment, so I can’t really offer a solution regarding drivers and the like.

When you say “Straight into the PC”… do you mean on the front panel, or in the USB ports on the back of the system? Typically, the ones on the front panel are connected to the system through a USB hub, which can be problematic. If you’re not already, try plugging them into the USB ports on the back.

You might also want to determine which of your USB ports are 2.0 and 3.0. Sometimes these devices have problem with Gen 3 USB ports. Make sure they are plugged into the 2.0 ones. (Usually the Gen 3 ports have a blue plastic separtor inside).

You didn’t say if you tried unplugging them and plugging them back in when it happens.?

Given you’re saying the problem ALWAYS starts when ATC talks to you, it almost sounds like there might be a conflict between the USB ports and the sound card? What Motherboard are you using? Is it a separate sound card or are you just using the default sound card on the Motherboard? You might want to check your Win10 device properties (under computer device manage) and see if any errors are occurring when the problem happens.

Autocorrect. My bad.

I have tested the devices. They are all working properly.

I see no error or issues in device manager.

I loaded up again and it seems to be when I get clearance from atc that it just stops. I was moving the YOKE from left to right the whole time I was setting up the 787. As soon as I was cleared……stopped working.

Never had this issue before the update.

I am also using VR. Oculus Rift

1 Like

When I was using a Logi / Saitek yoke a while back, I’ve had the driver crash on me. I found just hitting my windows start menu and running the Logitech Microsoft Flight Simulator plugin again would fix it.

I also have the Logi throttle and pedals. Never had it crash using just those. Only when the yoke was connected.

1 Like

Where can I find this plug in? I’m flying right now in the Cessna longitude. No issues. Seems to be the 787 and 747

1 Like

I moved your post to the Peripherals section. This is where discussions of yokes, rudders, and throttles takes place.

1 Like

I don’t have the Logictech drivers installed. I have used SpadNext with Saitek for years now. Always works, at least for me.

1 Like

which drivers are you using for the saitek stuff ?

How do I find that out please?

first it shows a page without content , scroll to the bottom and click on downloads
same page loads but now with content …

I will give it a go and let you know. Thank you so much

I found the page. I have a 64bit system. But aren’t the devices 32bit? I have the Saitek pro set up

I tried downloading the 32 bit update but tells me to find the 64bit download which I can not find.

I downloaded the trial of this. Same
Thing happens. As soon as I’m cleared to go……nothing works. It has to be an update issue