Saitek Logitech pro rudder toe brake issues

Hi all

All working well except ATC but that’s covered elsewhere. Added this rudder for the new sim to my existing setup and the rudder itself is great. Have an issue with the toe brakes.

Basically they are all mapped ok and work to a degree but it’s a bit weird with both L/R so it’s probably a me issue. In the assignment screen when pressing either it rises linearly from left to right as you press the brake from off to max. However in the sensitivity screen it starts at the top right then as you press down moves down to the bottom left through any dead zone and then heads back up again as you press more.

Watching squirrels vid when he tests his brake setup you can see they just move up and down. Mine don’t do that. Just like the sensitive screen as I touch them they bounce right down then slowly lift before slowly heading back down again as I press down through the range. Any ideas? Braking although works is pretty tricky as you can imagine!

Many thanks

Has a bit of a play and still can’t fix. Calibration in windows and in game all look good.

But as above it starts too right and moves down to zero as press the brake. It’s exactly at zero half way through the brake travel before moving back up again.

So can use them and just have to jump to 50% plus to apply the brake otherwise it’s going in the wrong direction! Reversing axis doesn’t help either it still goes through the travel twice in sim (well in the sensitive screen in the assignment it looks perfect) as opposed to just once in actuality. Will prob raise a support ticket.

Ok after a morning of playing I think they are actually ok. Did a check while actually in the air and they seem to operate in the cockpit fine. I had only checked in cockpit while on the ground and I guess the odd movement is from the parking brake! Doh!

Still looks odd in the sensitivity screen but perhaps that’s how it’s designed. So a me problem after all.

I don’t think they are correct as the deadzone is not properly applied. If you have a deadzone, it is applied when you hold the brakes at 50%

1 Like

Yes that’s what I see in the sensitivity screen. The bottom (should be the start?) of the travel In sim is at 50% of Actual pedal travel

I’m seeing this same issue


I’ve submitted a ticket for this issue, for what it’s worth.

1 Like

Just got mine work. Look for Left brake axis and right brake axis.

Mine look fine on that screen too. They simply move left to right as you press the brake. It if you go into the sensitivity screen and try in there, say to add a dead zone what do you see? How does it move for you?


Its been perfect so far! Be sure you have the brake axis, not just the left or right brake. That’s what I did at first.

Yes I definitely have the Left and Right brake axis set and on the assignment screen pressing them moves left to right as expected. In the Sensitivity screen the default (set at 0) is a linear line bottom left to top right. But when I press my pedal in there it starts at the top right and moves down to the bottom left at 50% and then back up again to top right at 100%. If you set a dead zone that then is at 50% pedal travel which cant be right. Does yours behave differently?

I have the same Problem with Thrustmaster Pedals!In the Cockpit the breaks move correct but don‘t work properly

Mine does the same thing but the brakes function properly as far as I can tell. The plane reacts similarly to the real Cessna 172 I fly.

i have buy honeycomb and now the work"!

Same problem here with the MFG crosswind (I test with the C152).

  • It goes from right to left in the assignment screen
  • In the sensitivity screen, it starts at the top right and moves down to the bottom left at 50% and then back up again to top right at 100%.
  • In the plane, looking at the pedals, they behave very well with full depletion of the brake when foot fully pressed.
  • Physically, it’s totally wrong when I press a single toe brake. The plane doesn’t turn at all. It’s impossible to simulate non symetrical braking. I was in the alpha and I never got it right.

Absolute the same here:
0% physical toe brake = 100 in-game brake
50% physical toe brake = 0% in game brake
100% physical toe brake = 100 % in game brake

Impossible even to take off with it.

As a work around for the toe brake issue as the sensitivity is bugged on the right toe brake for me, I used the legacy software and created some bands for each toe brake. I assigned the upper band to a button i.e. 50-100% button: Num *. You will have to remember to turn the software on before you fly. It works fairly well for me. I am using the combat rudder pedals. Below are the links: - sometimes page fails to load

Reverse axis box checked perhaps? I’ll have to go back & check my settings for toe brake using MFG crosswinds but I believe it should work fine, just a matter of getting the settings right.

And it is of course reversed yes, otherwise I would have to press them to roll :wink: