Saitek Pro Flight Cessna Yoke System - Predefined setup

Will there be a predefined setup for the Saitek Pro Flight Cessna Yoke System? Are they im/exportable?


I have this same peripheral… as well as the Saitek Cessna Trim. I would have expected it to work out of the box since it did for FSX. I’ve been using it for years. It’s still just Saitek/Logitech equipment with a nice Cessna logo on it.


I did have the same problem. My Saitek Pro Flight Cessna Yoke, well working on FSX, is recognized, but not with predefined functions. Actually, the predefined functions briefly popped up, but after half a second it disappeared again. It says on the FAQ that „other peripherals“ work, but need to be configured manually. As the Logitech Pro Flight Yoke is on the compatible list, the „sister product“ should do, too. I hope to hear soon of a solution from MS2020.


Also very disappointed having been looking forward to flying in the sim. Have a saitek cessna yoke with throttle and rudder pedals and separate throttle. The last two work but the cessna yoke/throttle are not recognized by the sim.

I sincerely hope microsoft could support the people that have spent hundreds of euro’s on these peripherals which should work as the sister product by logitech does.

1 Like

I have the same problems with the saitek cessna yoke. It ahows some mad catz driver in the list. For a short time it shows something then the page is empty and a question mark apoears. In xplane the yoke has worked fine for years. Also in MS X. What worked on the other hand are de rudder pedals. Lets hope for a solution soon. Until then i have to fly with an old joystick.

Well manually assign. Spend a few minutes getting the basic functions up and running.

Do a search on Youtube for Tutorial #2 - Peripheral Control Setup - Microsoft Flight Simulator

Excellent Tutorial

If you purchased the sim via Steam and you cant see your device in MSFS then scroll further down this forum and find the thread called… [STEAM USERS] If you controllers aren’t showing up in game

1 Like

Thank you very much. You made my day. Greetings from Switzerland

Thank you. I finally did the set up of the Saitek Pro Yoke Cessna manually and it works just fine. Now I am waiting to the remaining Saitek USB cockpit controllers compatible, which I believe will take a while. Greetings and thanks to all.

Hi, I have the pro Cessna yoke do you have any pictures of where to assign each button?


Hello. how did you do that?


Hi Manfred
I recommend to look at the Youtube Tutorial From Squirrel (Tutorial #2 - Peripheral Contrl Set up Microsoft Flight Simulator 2020). Well done and very comprehensive.

Rgds Andreas

Thank you very much, unfortunately I only spoke German, the video was too fast.


1 Like

Whilst the Saitek Yoke and the Saitek Cessna Yoke share the same drivers unfortunately only the Saitek Yoke was defined in FS 2020, so the Cessna Yoke does not show in control options. There is an easy fix that works (Steam users):

Go to (Disc you installed the game)
D:\Steam 1TB SSD\ steamapps\common\MicrosoftFlightSimulator\Input
In the Input folder search for:
Copy the file and rename the new copy to:

Now open the (copied) file you created with Notepad(++)
And go to the 3rd line, and add the Cessna word
**< Device DeviceName="Saitek Pro Flight Cessna Yoke "

Save the files and launch the game.
In-Game go to “Controls” and you will see listed in the top bar.
From here go-on and set everything up the way you like.

Hope this helps


I don’t use Steam. But the CD version of MSFS and I can’t find the “Saitek_Pro_Flight_Yoke” file to make the modification. Can you help me?
I don’t speak English, so I used an automatic translator. I hope it’s understandable.
Thank you in advance for your answer.

Hi Abdellys

Try to look where FS 2020 data is installed you could do a Windows Explorer search for the “MicrosoftFlightSimulator” folder or “Input” folder.

I unplugged my recognized and working Cessna yoke to move things around a bit and then plugged it into a USB hub instead of into the motherboard directly where it was and it stopped working. Once I plugged it back into the motherboard USB port it was back up and running again. My USB hub is an Anker powered 7-port hub, one of the supposedly good ones. I don’t know what the deal was but that worked for me.

Any news or update regarding Saitek Cessna peripherals set or predefines for MSFS ? will it work out of the box ? (yoke - rudders - trim)

1 Like

any news here ?

1 Like