Saitek Pro Flight Radio panel no longer lights up with SU 5? can anyone help?

You guys are right about the exe.xml. I don’t have one but I do not think I need it. but if that got changed that could be a issue. I always backup all this stuff before a change and after everything is stable again mostly to compare what might have changed.

You need it only if logitech driver and plugin is installed.

Just to add info:
I have the Logitech-Saitek radios, the switch and the autopilot and no problems with WU5.
But I have experienced several MSFS CTD after WU5. After restarting I got the advice that Logitech plugin was opened and once loaded MSFS all Logitech were out of service. The solution is close “LogiMicrosoftFlightSimulator” in Task Manager and restart the plugin (I have a direct access) then all Logitech works again.

1 Like

Thanks, I checked the roaming folder as I have Steam version and still no Logitech files in there :confused:

I will try again tomorrow, I feel I’ve exhausted every option today, maybe I’ll have a clearer head tomorrow. Hopefully they will acknowledge it as a known bug then I can stop worrying and just wait for a fix.

Regarding assigning a master avionics switch, I use the Honeycomb yoke which has a master avionics switch on it which works fine so do I not need to add a keyboard version?

Thanks for your help, I do appreciate everything coming up with suggestions, fingers crossed I can can fix it soon.

No need mate.

1 Like

Have a look at this post here. …

For those still having issues - this process works for me every time when using the Radio Panel since SU5:

  1. Assign a keyboard shortcut to the AVIONICS MASTER 1&2 ON if you’ve not already done so
  2. Once you’ve loaded into the main menu of MSFS, open the windows task manager and check that the Logitech MSFS plugin (LogiMicrosoftFlightSimulator) is running. If not (which it normally isn’t for me), manually run the plugin. I use the shortcut it created when I installed it, but if you no longer have that shortcut, then it runs the following:
    "<LOCATION OF PLUGIN>\LogiMicrosoftFlightSimulator.exe" --run --force
  3. Load up a flight, turn batteries and ground power on, then press the avionics keybind (in airliners). The panel should light up and work correctly.
  4. If this still doesn’t work, try closing existing copies of the plugin in the task manager, then repeat step 2 again. Once you’ve done that you’ll need to go back to the sim, click ESC and restart the flight, then repeat step 3

Hope that helps!

1 Like

So, I’m making ‘some’ progress. My radio panel lights up when I load a flight, but as soon as I press ready to fly, once I’m in the cockpit the lights go out again and it’s dead.

I have the Honeycomb Alpha yoke and have battery, alternator and avianoics mapped to that so I guess I don’t need to see a keyboard bind as well?

Whether I start cold and dark or on the runway the radio is dead.
The plug in automatically loads on startup for me, but I tried ending the processes and reloading and that does nothing either.

I feel like I’m so close…

Try assign key

toggle avionics master

Checklist is important :wink:

Ok I’l try in a bit. Not sure why it would work when I turn on the avionics using my Honeycomb yoke anyway and the radio lights up in game with that, (and before SU5 my saitek would light up at this point too), but I’ll load it up, assign the key and give it a go anyway. Here’s hoping…

btw is your best friend. Worth every penny.


1 Like

I have discovered the solution to this problem, and that is if you have the honeycomb bravo throttle quadrant, you must turn on the button 46/47 on the quadrant (the last flip switch to the right), when you do so, the radio/nav panel will work just fine again…

This is because they assagined the “Masteravionics1 switch” to the 46/47 button after the WU5, so just clear the button "46/47 " or reassign it to something else and then assign the Masteravionics1 to what it was assigned to before the WU5, and you would be good to go! I use honeycomb alpha+bravo, so I just reassign the Masteravionic1 switch back to the switch on the Alpha yoke (switch 17/18).

To all of you that have this problem but dont use the honeycomb bravo/alpha, check which buttons that controls the Masteravionics1, it looks like they reassign it to other inputs after WU5.
So it looks like it was a easy fix after all.

I am so happy to finally figure it out, since I acually stoped using MSFS because of this issue.
I really love using the radio/nav panel from saitek/Logitech. Playing with VOR dme frequency’s physically makes it that much more realistic and fun!!

I think it is a good idea to assign all your buttons again after the WU5, so you dont get any other surprises…


You absolute legend! This finally fixed it for me! I do indeed have a Bravo Throttle and pushing that button to turned back on again!

So relieved, THANK YOU! :smiley:

no problem bro :wink:

1 Like


I second that…YOU ARE BRILLIANT…FIXED my problem…THANK YOU.

I spent days, weeks and TOOOO many hours trying to fix this…all to no avail.

Like you, I use both the Honeycomb Alpha and Bravo and have not been flying because of my frustration in not being able to use the radio…I also like to play with the VOR, DME, etc.

Wish you all the best…and thanks again.


I have not problem with my Radio, Multi and Switch panels but today checking optional updates I have found a driver update “Logitech - HIDClass -”.
Maybe this can solve some problems. Any info about this will be welcome.

It seems like it wasn’t a bug but just the addition of a key bind by Asobo on the Bravo Throttle Quadrant, so those of us using the Bravo had to flick a switch to turn the radio on. What complicated the issue is that the radio in game does come on when you turn the avionics switch on and you can tune with the mouse, so we were left pulling our hair out as to why our panels wouldn’t turn on. If the radio stayed off in game we’d have worked out it was switched off somewhere but it displays as one and working in game.

Anyway, I’m so glad its resolved now!

1 Like

Thank you! I am just happy I could help you out as this issue really bothered me too.
It looks like this was just an issue for us whith the bravo TQ.
Happy flight!

1 Like

Same problem with SPAD which I normally use. Tried the logitech driver, yeah lights up but most of the buttons and switches dont work all since V5… Cant MS make a change without stuffing other things up??? I think they are using us as Beta testers…. I REALLY don’t want to do ANOTHER complete rebuild… I’ll try a few of the suggestion again, been building FS’s for many many years hence LOTS of experiences but this one got me… i’m already bald and can’t pull any more of my hair out!

It’s likely to be for the reasons mentioned above. Not broken but rather some of your controls have been auto reconfigured. For those of us using the Bravo Throttle Quadrant the sim had bound one the Quadrants switches (the far right) to the master avionics switch in game. If we didn’t flick that switch on the Throttle Quadrant the radio wouldn’t work, even if we are manually turning on the avionics in game with another button or mouse, and can see that the radio in game is on.

Check your controls for similar config duplications, it’s probably just a key bind that needs to be changed on one of your peripherals.

It’s frustrating to troubleshoot though.