Saitek Pro Flight Yoke and Throttle Quadrant purchase and setup

I just picked up the Saitek Pro Flight Yoke and Throttle quadrant at Office Depot on sale for $151.49 which seems like an okay price. Used a coupon (code 27273399) for another -$1.01 off then paid with a Honey Gift card for another -$14.10 discount for a net price before tax of $136.38. Shipping was free. Delivery is estimated around Sep 8. That’s close to a 20% off of the $169.99 regular price for anyone looking for this item.

Assuming the correct setup in Windows 10, are there any issues in setting up I should be paying special attention to?

It is just plug and play. Adjust your sensitivity to your likings and OFF you go.

Mine worked straight away, most people have no problems.

If you goof something up (despite being plug & play), it’s possible you’ll need to clear the registry entry. Logitech have a support page on that. You’ll know if this happens if the TQ moves erratically in the sim such as, it does nothing until you move the lever to 50%.

Otherwise, just mapping the controls is all that’s needed. Which can be tedious. Many work by default such as yoke control.

Look for a good price on the rudder pedals to complete your setup.

Sounds like a mostly painless process. I’m looking forward to using a yoke instead of a stick for a change.

The rudder pedals are also on sale but were out of stock. There are also things like the multipanel, radio and switch panels though I don’t know if their sale prices stack up. I was looking for the Saitek yoke so I had an idea of the prices to expect for that. Not ready to invest in a full instrument panel just yet.

You can get bargains on Ebay. I have already saved about £150, and some of the things I bought were new.

Mine has worked fairly decently since purchase. The only main issue I’ve run across, which may be either a driver or Windows issue is that after a PC sleep cycle, the Yoke will be out of calibration. I have found that simply unplugging and plugging back in the yoke fixes this though which is why I think it is either the driver or a Windows issue. One other thing to be cautious of are the stems on the throttle quadrant can be a bit fragile to torqueing motions. I accidently snapped off one of them near the base when moving my chair around one day and as the throttle quadrant that comes with the yoke plugs in with a PS/2 connector, it’s not as simple to get a replacement. Lesson is that when not in use, leave the Throttle quadrant in a full forward configuration. :confounded:

Great news! My yoke has shipped and should arrive on Wednesday, a week early.

I’ll probably have to remove the yoke and throttle quadrant when it’s not in use so hopefully no run ins with my chair or issues with sleep. I have hibernation disabled so windows just exits to the login anyway.

I should have everything broken in just in time for the next World Update.

Are there any mappings in particular that you would recommend from your experience?

The assignments are personal preference but here are a few of mine…

  • The larger red ‘thumb’ button on the yoke is autopilot engage/disengage.

  • Hat is free movement, not ‘snap-to’ views. (I recall the snap-to views were default)

  • Reverse thrust on the lower detent of the Throttle/power lever(s).

  • Trim controls on the yoke

  • Rocker switches on TQ for flaps, taxi, landing, strobe, gear. (But many uses here including battery, pitot, start, etc)

  • Left index is ATC Panel Choice 1 (so I can easily respond to many ATC commands)

Note: The Logitech yoke has a mode switch (right index finger). With software, you can have each of the 3 modes with separate programming. I was not able to get this work but maybe I don’t have the correct App for that.

Note 2: Setting yoke sensitivity will be important. Trial and error to see what you like,

Note 3: Calibration is performed by unplugging the USB connection. No need to use the Windows calibration tool.

Note 4: Be sure a key/button binding is unique otherwise things will appear to not work.

1 Like

Highly recommended for those who leave their TQ attached to a surface. I’ve been doing this since day 1.

If you go to https://logitech.com/support/yoke, you can download the Flight Yoke System software which supports profiles with programming for the three modes. I looked for some pre-made profiles for FS2020 but it looks like all the setups are being done through the flight simulator control section. I suppose I could try with an FSX profile that is available, probably minor adjustments only. With the software you can program the three modes to use the flight sims default keyboard commands and switch between the modes. It should work but I didn’t find anyone using it that way.

The Yoke arrived and I have it connected and mounted. I’m setting up the yoke now in FS2020 and I’ll use a number of your suggestions. Thanks.

1 Like

You didn’t because it doesn’t work with MSFS.

The Registry entry idea is a solution. I found this solution on this site for a problem with the Saitek yoke. (sorry can’t find the link again…) It was too abrupt moving left and down. I used the solution and it worked. Basically, it was to do with finding the right Reg for Saitek, deleting it and re-booting the PC. BACK UP THE REG FILE FIRST though.
As for this being a ‘plug and play’ set up… not what I found… difficult in FSX-SE and MSFS… X plane (dare I say it) No problem. As for the drivers for the throttle. Couldn’t and still can’t install them. Reported to Saitek. As have many others . Thanks to who gave the solution to my problem :grinning:

1 Like

You dont need any drivers for the Throttle Quadrant nor for the yoke.
Just calibrate them under Windows before use, bind the functions to the yoke (elevator, ailerons) and to the Quadrant levers (throttle, mixture, propeller).
Verifying axes direction by starting on the runway is the simplest way to do it (some axes sometime needs to be inverted).
For yoke and quadrants buttons, it’s more a personal choice of wich functions you want to have directly under your fingers.

1 Like

Thanks… Helpful. I’m getting there. I read somewhere this was he case (re: drivers) Shame it’s not more explicit.

Saitek/Logitech say that simply unplugging the USB is what calibrates it. That works for me but the Windows tool may also be ok.

1 Like

Haven’t found any yet, but are there any video tutorials to assist with setting up the additional throttle quadrant to a twin engine prop