Saitek Pro Flight Yoke konfigurate Hello, everyone, I have now spent many hours configuring Saitek Pro FlightYoke, Saitek Rudder, and TPM system, but without success

Hello, everyone, I have now spent many hours configuring Saitek Pro FlightYoke, Saitek Rudder, and TPM system, but without success.
All drivers are up to date,all are recognized by the sim,Sensitivity can be set up,I have implemented the tutorial step by step,What else can I do? greetings: Manfred


i have the same problem!

1 Like

Mine was configured automatically when plugged in. I didn’t realize it until I tried to configure it.

have you fix it?

What’s happening? If you have them being recognized by the app and you set up the configuration and sensitivity, what the issue? My Logitech Saitek yoke, rudder, and TPM work fine. But the Saitek switch panel and multi switch don’t show up at all. My PC shows the devices as connected in the Windows Setting Device list, but I can’t get them to show up in FS2020 Control Settings section, even for manual mapping & configuration. They just don’t show up at all. I even purchased a 3rd party software called Thomas something. That got these devices to light up for the first time when FS2020 is running, but they still don’t show up in the Control setting in FS2020. Also the 3rr party software that’s running in the background causes my FPS to drop from 60 FPS to 15 FPS and eventually causes FS2020 to crash after 5 or 10 minutes, so the software is unusable.

No, I don’t see any more chances.

1 Like

same here i tnink we must buy Honeycomb Alpha Flight Controls

JUBEL!!! :joy: :sweat_smile: :sweat_smile:

I have managed to configure my controls, in the aircraft upper menu bar AI control everything from

exellent me to

Same here, it’s not working, i even have it does work with it but then i have a loss of 50 fps… so can’t use it.

Just the yoke & rudder pedals work without third party software.
Here’s a tutorial to configure de yoke, but in spanish.

My yoke works for a while …then just disappears.

When I open the device properties / Hardware Tab (Win 10 Pro 64bit) this is what I see:
!. When the yoke is working:
Flight Yoke System (HID)
Flight Yoke System (USB)
Generic USB Hub

After the Yoke has disappeared / failed:
Generic USB Hub

This happens with a powered USB Hub, or connected directly to the PC

I have installed and uninstalled the drivers a number of times.
When I use the Logitech 3D joystick on the same port, there are no problems.

I am using the yoke with the throttle quadrant. (N0 pedals for now)

Any ideas?

found some links for Saitek Multiswitch panel, working well
go to logitech support search under support type in

Try changing your power management of the device so Win10 isn’t allowed to control it.

has anyone tried spadnext.
its software to program saitek panels for fsx xplane p3d. as it uses simconnect it will probally support msfs too.
its free trial for 14days to see if it works before you buy.
also youtube search for ‘blank saitek display’
. it shows how to disable win10 power management which has caused problems too

i cant change the default profile to my created preset profile… see attached picture

pls help… thx

can, you give little more detail pls?

If there is nothing else configured you can‘t change the profile. You need to change assignments, apply them, give the profil a new name or accept the automatically given name and then make sure this profile is selected.

Of course it could be that SU5 has messed that up too, Idk.

As a well meant suggestion: get Axis And Ohs and delete everything in the MSFS assignment menus. I was so tired of the problems and weird, inconsistent settings so I transitioned everything to outside and haven‘t looked back.