Saitek switch and multi panel issues


I have installed the latest saitek/logi drivers, my radio panel seems to work well but nothing else, the switch panel doesn’t react to any knobs or switches, even in an a/c with retractables the 3 greens don’t light up. and the multi panel display lights up with 0000 but no buttons respond except the flaps button which sort of jiggles the lever in the sim and makes a sound but doesn’t retract or extend which is really strange.

I installed spad and everything worked fine, now that the trial ended I don’t really want to pay for it. The logitech test exe shows all buttons are responsive.

I disabled usb power saving, all plugs go directly into the motherboard headers. Not sure what the issue is, I know this was discussed to death earlier but the latest drivers seems to fix it for everyone else.


I just set mine up tonight and I actually had to unplug and plug it in a few times to get it going but finally did.

That said, I did find this video (wasn’t my issue) but maybe will help?

thanks yeah I did disable that (there is an easier way, USBEnhancedPowerManagementDisabler.exe which does it automatically for you)

Well after plugging and unplugging several times now my multipanel and switchpanel works and my radio panel has stopped (no lights at all) I can live with that don’t really use the radios but something pretty weird going on.

Two things I noticed. For some reason the SAITEK/LOGITECH panels seem to like USB-2 and not USB-3. Also some USB hubs seem to be under powered and the SAITEK/LOGITECH panels need a good supply of power. I am still having problems with my SAITEK/LOGITECH panels, They turn off after 5 minutes. I did everything suggested in the YouTube movie and even bought one of these to check my USB connections. Any suggestions would be most appreciated. Thanks in advance…

All my panels work… the only thing I noticed is that the Longitude acts strangely with the switch panel. It still turns things on and off, but the indicator lights do not light and every time you manipulate anything on the switch panel, it turns off the panel backlighting… very annoying at night

1 Like

Mine only likes USB 3, and not USB 2.

Same here, only with the longitude and after the last update.
Light switches don’t work anymore, gear and pitot heat still working normal … all other panels still working fine.


it was a good suggestion about usb 2 vs 3, I tried plugging my dead radio panel into a usb 2, and it worked, woohoo, but guess what my multi panel then stopped functioning again. it seems adamant to not let me have all workign at the same time.

My years of pc experience tell me this must be a conflicting usb resource, but I keep coming back to the fact that if I reinstall spad it works perfectly, and the logitech provided test app works perfectly on all 3 devices even at the same time.

Do they both show up in the printers and devices menu (shown in the video I’m posted).

When I switched my ports one showed up but not the other. I had to unplug and plug multiple times and it finally showed up in there.

Once it did, it kept on working after reboots etc.

You may find that you need to map a key to avionics master and toggle it.

yes all 3 panels show up under devices in control panel. (plus my yoke, trim, and pedals)

avionics master toggle does turn off/on the displays.

Plugging and unplugging really does help, I am now at the stage where all 3 panels work, except for one key and that is the flaps lever on the multi panel (ironically of course its the only one I actually use). Pressing it on the panel shows the lever in the VC “jiggling./vibrating” so seems to be trying to do something.

I might have to try fsuipc and see if I can map that key to the flaps manually.

ok finally solved it. What I did was:

  • go to C:\Users*uname*\AppData\Roaming*yourMSID*\1250410 copy that folder somewhere then delete it. Now when I ran the game it acted like it was the first time and I had to go through setup steps again.

I then did a flight and all 3 panels worked including flaps. yoke/pedals/trim did not work because they did not have profiles so that was expected.

Close flight sim, then copy the 3 files for my controllers (named inputprofile_*) from the backup you just took back into the real folder.

Run flight sim again, still flaps lever worked and all panels functional, and all controller settings restored.

So I cannot really explain it other than something was corrupted/left over from an upgrade in that folder.

Well after five minutes if I turn the encoder knob on the Logitech auto pilot panel the whole panel locks up and I have to restart my computer to get it to function again for five minutes. I will try your suggestion. I flew X-Plane 11 recently and ALL the panels work ALL the time. There has to be some problem with the interface in FS2020. Thanks for the suggestion.

I am also having this issue. Sometimes it takes 5 min, sometimes 20 minutes, but my multi panel is also freezing randomly. Any light would be much appreciated

I couldn’t find the folder you suggested. Could you maybe try to clarify me? I am having random saitek multi panel freezes every flight. Radios and Switches are ok.

When it freezes are you hearing the 3 audible tones like you plugged or unplugged a USB connection?

I ask because I had this issue of that panel freezing but was followed by the USB connect / disconnect sounds.

Turned out the USB hub was overloaded and panel was drawing to much power so had to move it.

I don’t hear that nor receive any message. But I noticed sometimes the multi panel gets a little bit unresponsive, kinda sluggish. That might be it. But I am not using any external hub. Each gadget is connected to a 3.0 usb directly on mobo. These freezes are rare but my CH Eclipse yoke seems to be glitching sometimes. It seems like a disconnect/reconnect in less then a second. The only thing it doesn’t make me think it is power is because all the other gadgets work alright. Only multi panel has freezes and the CH these awkward behaviour.

All of my devices were plugged directly into the pc (13 USB and 2 USB C) and that’s what was overloading.

I bought an external USB hub that has a power plug to the wall. Moved the panel over there and issue went away.

As a test you could unplug a bunch of stuff and just run the panel and see if it still occurs ?

Same with me. X-Plane works but not MS FS.

Download Microsoft Flight Simulator Plug-in

Install Logitech plugin

Launch msfs and go to controls options.
Assign key or joystick button to Toggle Avionics Master

apply and save

Go to world map and select departure > fly.

Pre-Flight Checks (example below).

  • before starting engine
  • starting engine/s
  • press toggle avionics master key or button