Saitek X52 does not show

Hello guys,

I have the problem that FS2020 doesn’t show my Saitek X52 joystick.
I can only see mouse an keyboard as controls.

I have tested my joystick with other games (FS-X, Combat Flight Simulator) and there ist works.

I have disconnected all other controls, started the simulation several times, stated my system several times but nothing works - I can’t see my joystick as a controlle.

I use X52 pro, all I can suggest is disconnect, reconnect and maybe reboot…

Steam version?


Unchek the XBOX ConfigSup

Thank you… I have this several times…
Unfotuantly ist does not work.

Unplug the X52 and after unchecking XBOX re-insert the usb; the controlle rwill show up in STEAM and if you dont own MSFS in STEAm the x52 will show up in CONTROLS.
Let me know

YOU ARE MY HERO…

thank you very much.

Problem solved :slight_smile:

I know I know… :wink: https://flightsimeindhoven.com/

Problem with FS2020 on PC. X52 show on FS2020 settings without ajustments and don’t work. In windows settings all are ok (sometimes mouse goes down…). It’s a FS problem because it work great with DCS World.

Read this: https://flightsimeindhoven.com/category/microsoft-flightsimulator/controls/x-52/

No steam version but Microsoft store

The fact that this was the problem/solution is crazy to me. Thanks for your help! I spent hours trying to find anything about this.

You’re a legend, after 5 days of frustration my yoke and rudder pedals are showing up in the sim once again.

Mine seems to be working just fine so my suggestion would be to make sure you’re completely up to date on Windows. Also make sure that your joystick is plugged into a 3.0 USB port. I did have some problems with the joystick until I made sure was plugged in correctly.

The controller specs are USB2

1 Like

Yes I know but for some reason msfs would not see the joystick until I plugged it into a USB 3. Strange hu??

@Adam: Do you perhaps have Steam apps on the machine?

With the Steam edition of MSFS, when a gamepad is present MSFS won’t detect my Saitek Flight Pedals. Windows Control Panel, Devices is happy with everything. This seems to be true for any gamepad - Xbox One, PS4 Dual Shock, etc. Disabling the game controller in Steam allows the pedals to be detected, but the gamepad drops out. Gamepads are really handy for camera control and for basic flight control when you don’t have a joystick (like me). Any idea if this can be sorted out?
Also considering MSFS2020 is an Xbox Studios product, the Xbox gamepad problem is particularly worrying.


Set to Forced out and in Big picture game controller will show up

Yeah I tried that. I’ve currently got Forced Out set. I read about that from posts elsewhere. The Xbox One controller still doesn’t detect in MSFS. The pedals are ok. My PS4 dualshock detects as a Wireless Controller; even though it’s plugged in via USB. Unfortunately the controller in MSFS has no mapping. So that’s a pain to go through. But strangely, the Xbox One controller is still not detected by MSFS with the pedals plugged in. I’ve checked for conflicting USB VID/PID and stuff. Nothing of interest found. Windows is quite happy with both the pedals and controllers at the same time. So I can only guess it is something Steam is doing. But I don’t know how Steam support controllers - other than enabling support in the Steam client.

Really hoping I don’t have to buy a different variant of MSFS. Already spent too much on extras.