Saitek Yoke Pitch Issue

Thanks so much for all that info. Just carried it out and it did delete the previous problems but the problem still remains. I pulled this out of the notepad for the new Yoke Profile I just created so don’t know if this is relevant or looks right -

1042

Cheers again!

‘profiles’ that should read, not ‘problems’ :slight_smile:

1 Like

I believe that is the “code number” of the selected function.

Ah, ok so not really relevant to this prob.

1 Like

Problem solved! Took a different route and used system restore back to the day just after installing MSFS. That worked so it must have been a corrupted file somewhere in the system that remained with every reinstall. Anyway, thanks to everyone offering their time and advice. TheSevenFlyer, thanks for all that detailed info, much appreciated!

Oh Wow!!
That’s great news.

Good Flights!!

hi, i´ve tried everything in this post but nothing works. My joke ( saitek proflight) keeps not working properly. everything work fine EXCEPT the main yoke, pitch and roll, that go full up,neutral and full down. No transition , no sensitivity at all ( tryed everything ingame). the rest of the yoke works in all the range of movement, smooth and perfect reflect of the angle of the lever. ( Saitek pro flight yoke and rudders, Single engine ).
With the properties of W10 (64bits) and Xplane 11 works perfect. Same faliure in FSX.

Hi, I had exactly the same problem with my Saitek yoke and rudder system and mine worked in Xplane as well but not in FSX or FS2020. In the end, it turned out to be a corrupted file. I had to do a system restore to the day just after I installed FS2020 and that fixed it. Everything else I tried didn’t work. Hope that helps! Mark

i, i already did that. didn´t work either. Got another saitek pro yokes , and same problem… starting to get really lost … everything works on W10 and Xplane 11 but not in FS2020…

anyone knows whre to find the sims configs files to see the problem and solve it?

Finally founbd a solution. weird, but it worked out.
The saitek proflight yoke system doesn´t have a calibration tab on the control panel/hardwareandsound/devices/ properties. I thought, as many i guess, that it “autocalibrate”. Seems not. Found a youtube video explaining how to set a calibration tab in the yoke properties. Did it and it worked ( recalibrate the yoke). RISKY because you edit the W10 ( in my case) registry and changes the appearance of the properties window ( you lose some W10 yoke options,deadzones tab, and visuals),but having the specifc programs, i think is acceptable. Here is the link .

Use it at your own risk.
Cheers

The simplest way and not risky at all is to click on “Search” type “joy.cpl” do “enter” and you’ll have your game controller window.
Making a link to “joy.cpl” on your desktop will be the best.

Wow, great news, happy flying! :grinning:

A handy tool for fault finding input devices is DIView
It will basically show you what the device is really doing.