Saitek Yoke Pitch Issue

Hi all. Just installed fs2020 with a Saitek Pro Yoke. Everything went fine and did some first flights. I experimented with sensitivities etc. all fine, the yoke was working smoothly. Came back on another day and the elevator pitch went very strange in that when I pull the yoke back or push forwards slightly, it jumps to the extreme of each pitch up or pitch down making the plane unflyable. This shows in the calibration part as well. The white line jumps straight to the left or right rather than moving gradually left or right as with the ailerons calibration which works fine. I re-installed msfs 2020 and it’s doing the same thing again like it’s locked in the problem somewhere. I tried the same yoke with the X-Plane 11 demo and it worked fine. Any ideas anyone? Many thanks!

Hello there!
I have a Saitek yoke as well, this shouldn’t happen.
Did you confirm if the sensitivities had changed ? (it has been known to happen!)
I you didn’t already know, it will very likely have to use quite a large negative sensitivity setting.
Are there any piloting assists on?

Hi, thanks for replying. Sensitivities are on -70 and no piloting assists on. If it didn’t work with X-Plane, I would think it’s a hardware problem but it’s fine with that, very strange!

Do you have any mods in the community folder?
Remove them (or rename the folder, MSFS will make a new one) and see if the issue persists.

It sounds like it might be a conflict.

No mods in the community folder but will try renaming it, worth a go. Def sounds like a conflict as you say. Thanks again!

No if you have nothing in it it won’t help.

Can you post a screen shot of your sensitivity settings?

Will post a screenshot and will leave out the folder idea. Cheers!

Here’s a screenshot -

I had to recheck my settings, as I normally use FSUIPC, but I keep a couple other profiles.
I have my default profile set at -48.
If that doesn’t help, try playing with the reactivity setting.
It helps with rudder issues that have a tendancy to go hard to one side or the other, so it could help this as well.

Just resetting msfs 2020 once more so will try those settings you sent and try the reactivity settings again once installed. If that doesn’t work, will try a clean re-install as the normal re-install leaves about 90gig of data behind. Wondering if something in the registry has been stubbornly left behind affecting the yoke.

Thanks again!

I saw and heard this rare problem in the past about the Yoke. In all cases it was a hardware problem due to the Yoke it self. You could try to fasten the connections at all sides. Yoke and Console. It fix the problem temporarily or not.

You could also test the inputs through a software that is analysing the resolution / inputs and noise of the Yoke.

No success = A return is at the end recommend.

I wonder though, the poster mentioned it works fine in Xplane11.
Would this occur just on MSFS?

1 Like


Does the yoke work normally in “Game controller settings” in Control Panel? Try out completely resetting the Controls tab, and only setting up the X and Y axis, and see if the problem persists.

1 Like

Sounds like a conflicting control on for example the keyboard set up that is used by the yoke. I had similar in the beta.
Do as GaucovyAero says

Hi all, just re-installing the whole sim again (probably a waste of time and not sure anyway if all the files have been cleared out in the re-install) so will try out the suggestions and report back. I also read about the rare yoke problem in the past being a hardware problem. As it’s working fine with X-Plane and also reading normally in the Logitech recalibrate controller axis program, it probably is a conflict in MSFS. Will try the complete Controls tab reset when installed again. Cheers!

1 Like

Ok, here’s 3 vids. One is of the game controller set up, (apologies for the cluttered screen). The second shows the problem and the third shows the problem in the sensitivities screen. This is all really weird!

Trying to think if anything else could be clashing…

You might have the right idea about a control conflict (clash).
It will be good, in any case, to eliminate that as a potential cause.
You can do that in the search section, right below sensitivity.
Use both “search by input” and “select an input”.

Just searched for elevator and checked selected all inputs, seem to be no clashes…

At a loss now, wondering if there’s a corrupt file somewhere. When I re-installed it, it wasn’t a clean re-install. It still had the controls profiles from the previous install.

That is the way the sim was designed.
It restores your setting with a re-install.

This is how to remove the settings.
Goto: c:/users/(username)/AppData/Local/Packages/Microsoft.FlightSimulator_8wekyb3d8bbwe/SystemAppData/wgs folder
There should be two folders there, one called “t” and the other with a huge alphanumeric name like 000901F6… Open that one.
Under that folder, there are a bunch of other Alpha Numeric (ie 69D9FE4C2AB94940B11A4D26A23A9561) name folders. Open each one, and you’ll find a container. file, and then another “file” with another huge alpha numeric name (i.e. A1036E4CDAAB21882AD5630E81466F). Open that file up with NOTEPAD or NOTEPAD ++. If you get nothing but screen barf, exit out and go to the next folder. Don’t touch that folder.
Go to the next numbered folder and continue opening the alpha numeric files. As you go through these folders, some of those alpha numeric files will contain your controller data that’s easily readable… If you find one, exit the editor and delete the folder it’s in.
Delete all the folders that reveal they belong to a controller until the only thing left are Number folders with alpha numeric files that can’t be read.
Restart Flight sim. All your previous profiles will be gone, but now you can plug in peripherals and use the DEFAULT profile. You can EDIT the default profile and save it, as long as it has at least ONE assignment, If you try to save an empty profile it will crash.