Saved MSFS flight plan redirects via North Pole and won't keep it's shape


Just looking for some help with my MSFS flight plans, please. I typically fly a leg and afterward I’ll go into the MSFS world map and plan my next route, creating various click points that I wish to see between my departure and arrival airport. Then I save it as a .pln file and try to load it the next night I get time to fly.

However, this process no longer works. Each time I load my saved .pln file the MSFS world map changes the shape of the flight plan, removing most of the click points I created and redirects the flight plan via the North Pole.

I’m using MSFS world map to create the flight plans. I can’t figure out what I’m doing wrong. Can anyone help, please?

Happy to upload one or two photos of the specific issue if you think that will help.


Do you have a Navigraph nav data subscription? North Pole waypoint bugs existed a while back due to some rare coding errors, but I think those were all fixed.

Are you loading an old .pln that maybe was created with an older version of sim nav data?

You could try loading in Little Nav Map, re-exporting, and load the new file and see what happens.


You can only save a .pln file before you click “FLY”.

1 Like

Agree with the Navigraph thing. Typically when I download a plan for a group flight posted here, and just bring it into MSFS, it goes to the North pole. If I import the plane into LNM, which also has Navigraph data, then export it from there, then the plan works.

1 Like

Yes. I do have a Navigraph nav data subscription.

The issue was occurring even with new plans that I create, including one I tried just before posting my message on the forum.

However, I went into my Navigraph application and it appears as though my nav data was out of date. I updated the application (haven’t used it in ages) and then performed data updates. I did this whilst the sim was closed.

I then loaded up the sim and tried to load an old .pln file I had created several weeks ago. It worked perfectly in the world map section and all my click points were correct. I also tried creating a new plan and it also worked which is great.

Thank you, and also to everyone else that replied - very much appreciated!



And I think that is the issue, non-matching nav data. Glad you got it working.