Scenery and airport not loading at arrival

Been having a strange problem lately that hasn’t happened before.

Only happens with my third party airports and sceneries. My sceneries load fine at my departure airport where i spawn. But sometimes the airport and scenery at my arrival do not load. Everything is just flat.

But in a different flight when I spawn on the scenery/airport that failed to load before, they load just fine. This doesn’t happen with handcrafted Asobo airports.

So far it has happened to me for the following sceneries:

Samscene3d Guangzhou ZGGG
Flytampa Vegas KLAS
Feelthere KLGA and Samscene3d New york

Anyone else encountered this?

2 Likes

The objects could be LODs-meaning that you will not be able to see the scenery until you are in a certain radius of an object.

Does the scenery not show up at all even when you are close to it?

Yes. Even tried setting the LOD to 400 while parked at a gate. And turning online functionality on and off to make sure it’s not a streaming issue.

Airport still doesn’t load after 15mins.

1 Like

I had the same thing happen to me with Feelthere’s KLAX. Flew from Atlanta, and had to land on a satellite photo of a runway. No buildings at all – basically, nothing loaded. Deleting the rolling cache and re-enabling it brought back the ground textures, but not the buildings. They never reappeared.

This is with the SU10 beta, by the way.

Did it ever happen again on a different flight?

I am having the same problem. The (addon) scenery of my arriving airport does not load in and I land on a satellite image of the airport. No real RWY, buildings or what so ever.

Strange thing is that when I choose the same airport as my departure, the airport loads in perfectly fine.

I can recreate this failure as often as I want. Happens everytime independent of flight time or aircraft.

Tested: FSDT Zurich (inbound from LSGG)
Tested: Orbx Vienna (inbound from LSZH)
Tested: Fenix A320, FBW A32NX, Asobo 32N, PMDG738
Happened before and after installing SU10

Please share your opinion on what I can try to fix this as it’s no fun anymore flying like this. @ASOBO please fix!

Do you have both GSX and AIG traffic installed?