SDK Terraforming height = different in game?

Hey guys

Setting ground terraforming height in SDK saves as a completely different height in game.

For example I smooth out an taxiway at 100, save / build / put in community folder, in game its a different height at 120. It’s as if the SDK scenery mesh is different to the in game mesh?

Am obviously missing a snap terraforming to ground or I guess a compiling setting but can’t for the life of me find it, any help or point in a direction would be much appreciated, cheers! :beers:

Did you recreate the airport as have a feeling the taxi way and airport overules scenery edits unless you recreate the airport itself.

Cheers for the reply
Airport is set up correct. Tried a test this afternoon with both an airport and no airport with the same result.
SDK edit > In game result

Feels like something is multiplying the edits I make, a terraforming brush is bugged or there’s an issue with the scenery mesh? Cheers

could try the fix i use when a few times the vegetation tool won’t work for me. doing this will reset the dev mode camera option to default. it will redownload those files next time you start the sim up.
This works for the above issue may work for this.

Just delete the files circled in screenshot:

1 Like

Much appreciated! Its silly o’clock here so gunna crash and try in the morning, will update back, cheers.

1 Like

Hey, have you guys found a solution? have the same problem here…SDK looks good, when I put the folder in “community folder” the terraforming are with the wrong height

@Bairro8387 Unfortunately not yet. Following chats on other forums like FSDeveloper there’s a handful of us that have run into this issue, looks like we’ve found ourselves a genuine bug! I’m in the process of submitting a Zendesk bug report (Submit a request – Microsoft Flight Simulator Support) feel free to add your own to hopefully get us noticed!

My work around has been to either spend hours moving heights 10ft a time till the in-game is correct or alternatively and much faster, just make custom objects that work with the scenery as it stands. (Realise that might be complex depending on where your skill set sits). I have found terraforming works brilliantly in some areas but not others, thinking its a bug with how certain parts of the terrain mesh records changes made to it with the tools.

I’ve got this thread on watch so will update if and when I know more, best of luck! :+1:

1 Like

I don’t know if this is relevant to this post but I thought let me share it anyway. Every time I load my edited airport into the editor I have to delete rolling cache, which is off btw, first otherwise the taxiway and runway are up and down like a rollercoaster.

I have terraformed a piece of the airport before and deleted the polygon afterwards as it didn’t fit but its as if the project still loads the terraforming or messes with the terraforming hence the rollercoaster effect. As I said the only way for me to dodge this pain in the back is to delete rolling cache before I start to edit my project.