Seattle landmarks causes CTD

I’ve been having some issues trying to land on KSEA 16L. I have Drzewiecki Design Seattle Landmarks installed, and now I believe that this is the culprit. When I was about to turn on final on 16L on an IFR flight, immediately the sim CTD. I tried several times, form different airports and different aircraft, with the same results. I was trying to figure out what could be the cause of this crashes, and I even lowered my settings to see if it helped but it was the same even though my PC is more on the high end side. I decided to approach from the other side, using 34R , and I landed with no problem. I then uninstalled the Seattle Landmarks and sure enough, that took care of the problem. It is very strange because I have done many take offs from KSEA and flew around the city with the landmarks installed and had no issue. I think that perhaps because there is so much clutter on that side and then adding the landmarks maybe is straining my system? I don’t know, but I will request support from them to see if it is lack of optimization or a code issue. has anyone had this problem?

It is probably a conflict with some of the changes ASOBO has introduced.
I would take this up on their forum.

I have the same Drzewiecki Design Seattle Landmarks installed, which I purchased from the Marketplace. Tonight I made two takeoffs and landings on runway 16L, and had no CTD problems . I was flying the Cessna 172 G1000 (with the G1000 mod). On the second flight I set up an ILS approach to RWY16L (110.3) and initially it captured the localizer and glideslope but I had to turn off the autopilot and land manually when the altitude was about 500 ft. because it deviated from the runway. Hope this is helpful.

It really wasn’t a problem with procedures. I was just about to turn into final on 16L but as soon as I did, the sim just crashed. That was with the TBM. I tried the same approach with the Cessna as well with exactly the same results at about the same point. I did it coming from a different airport though.

Check out this post.
It may not be your scenery.

Yes, Microsoft told me to download the C++ packages, but the link was too general and it wasn’t giving me an specific file to download, so I decided to leave it alone for now. Now that they found the issue I will wait for it.
Thanks for the info. :slight_smile:

1 Like

Here is a pic of what I have.
You only need the bottom two as far as I know.
Check to make sure you have them first.

Mine is actually newer than yours I think:

1 Like

Then you are good to go.

It turned out the culprit for the KSEA area CTD was, for me anyway, caused by KTIW. I’m still waiting for ORBX to come up with an answer.

1 Like

Closing topic as solved.
As a reminder: The Bugs & Issues section of the forum is for MSFS default only - per the guidelines of this section. No 3rd Party, add-ons or mods. Remove all these items and test MSFS. If there’s an issue after removal, then create a topic.

Topic moved into 3rd Party Discussion > Scenery Packs