Seneca V PT 34 GNS530 not powering up

Please tag your post with #pc and/or #xbox.

Are you on Xbox, Steam or Microsoft Store version? MS Store

Are you using Developer Mode or made changes in it? Yes, No

Brief description of the issue:
When turning the power knob on the GNS530 the AP comes on but nothing else. The 530 screens remain dark. Same condition exists for all liveries.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue: Did not ow the Seneca prior to Update 7

As this is a 3rd Party aircraft, moved into #third-party-addon-discussion:aircraft

I flew the seneca v yesterday without issue. But I usually start from my flights on the runway so that aircraft is already started for me. Is this from cold/dark in a parking spot? Is it the same issue if you start on the runway?

I start cold and dark but use the E key to auto start. I’ll try it your way and see what happens. Thanks for your response.

OK. Thank you.

The manual start on the Seneca isn’t that complicated, I would recommend trying it. I think the auto start is a bit funny about not actually powering everything properly.

That being said, the thing I would check is to verify that the avionics power switch is on. The label on the switch itself is “Radio Master”, but it controls the GPS stack as well. It’s located just to the right of the Pitot Heat switch.

While you’re there, double-check that the Flight Director/Autopilot switch right next to it is also in the right position. It’s a three-position switch, where the middle position turns on the Flight Director (a little yellow inverted V on the attitude indicator), while the top position enables the actual autopilot.

If you have trouble finding the Radio Master switch, I can try to take a screenshot for you.

Thank you. I found the switches and will try the manual start procedure.

Hello, again. "Thank you for your suggestions but it is “no joy” with the problem I am having with the GNS 530 in the Seneca V, and I forgot to mention that the Bendix/King has the same problem. Still no life when I try to power them up.

I’m a total greenhorn when it comes to things like modifying CFG files, but I wonder if there might be a missing code string in the panel.cfg for the Seneca. Would it be possible for one of you who has it, to send me a copy of your config file so I can compare? Thanks!

Ah yes another update. This might cause some problems with our favorite Carenado planes. I guess I wait a week or two before reloading my Gamepass untill the Carenados are patched. :slight_smile:

Is the other GPS the GTN750 fully functional?

GTN750 is not functional either.

Try NOT using autostart per STRG E but using the tablet and set the state to ready for taxi. There is probably just a switch that STRG E doesnt fire up or is wrongly fired up, because it is a 3rd party aircraft.

Have you updated the GNS530 to the latest version? Was having the same problem in all my planes that use the 530 until I updated it. All good now.

Hello. I am happy to report that the GNS530 issue has been solved, The problem was that I had JDs - GTN750 on Others - MAIN MOD and ZZZ JD CAR PA34 Panel 01 GTN750 files in the community folder. When I removed them–BINGO!

1 Like