Shimmering/Flickering in Quest 2

Hi there

This is my first post in this forum so please be patient if not everything is correct…:wink:

I know there was reported similar threads about the same topic/problem. But I didn’t find the same issue I have and so I post it.

More than one year ago I bought the Oculus Quest 2. I use it only for the Flight Simulator 2020. From the beginning on I have a weird problem and till now I didn’t find a satisfying solution:

Often, when I put on the VR-device in MsFs there’s a shimmering/flickering on the left side of the screen. Sometimes it’s weak, sometimes stronger. It’s clearly visible on the left side of the cockpit window. And it’s visible normally on both lenses of the device. For 95% it appears when I put on the device on MsFs for the 1st time. BUT: When I put off the device for a few minutes and put it on again (same circumstances), for 50% the shimmering disappeared. The same thing I determined when I put off the device for a longer flight and put it on after 30 – 60 min. for the approach. I don’t know why the problem is gone after that. But unfortunately only for 50% this works, for the other 50% the problem still exists. For a whole flight it’s annoying. And sometimes it’s getting weaker during I have the headset on, but it does not disappear completly. When I do an activity from the MsFs-Menu (Discovery flight or landing challenge) the problem often doesn’t occur. And when the problem is fixed during a session, normally it remains vanished for the rest of the season (till I restart my PC and/or MsFs).

For info: I prepare my flights in the PC-Mode, and before I start the flight I switch to VR-Mode.

Interesting thing: When I start the device and start the Oculus Link (using Link via cable) there’s no problem, no flickering, no shimmering, also in the Link-Menu I have a clear picture. The problem occurs only in MsFs (doesn’t matter which airplane, airport, scenery or livery).

I looked in the internet for a solution (FS Forum, Oculus Forum, contact Oculus support, youtube, a.s.o.), but nothing helped. So I really appreciate every kind of help.

Here’s what I tried so far:

  • Changing the cable: First I used the official Oculus Link cable. My PC doesn’t have an USB-C box, so I used an adapter. About 4 months ago I bought an 3.0 USB C to A-cable. First I saw an improvement (80% good quality after I put on the device for the second time in MsFs), but about 2 weeks ago the problem increased again.
  • Put in an out the Link cable and start Oculus Link again or the Oculus app and device as well.
  • All systems and drivers are updated.
  • I tried nearly every setting in MsFs VR-Mode (Rendering, Terrain Level of Detail, Anisotropic Filtering, a.s.o.) and in the Oculus Tray Tool and Debug Tool (ASW - off, auto ,adaptive – FOV Mulitplier, Link settings) and also in the Oculus app (72 to 120 Hz, several rendering options). Also with lower settings the problem exists.
  • I changed the Oculus tracking frequency in the Headset settings.
  • I tried out several light situations in the room (dimlight, darker).
  • Audio on a loudspeaker and not on the headset.
  • In the Oculus App Beta channel off.
  • In OpenXR I switched off the motion reprojection and the the latest developer preview.
  • Press the window button on the keyboard.
  • Photogrammetry off.
  • I use only one PC screen (not several ones).

So, the main problem is: I don’t find the cause of the problem or any logic behind it. The problem occurs with several circumstances, but sometimes everything works perfectly and smooth.

My technical specs:

  • Windows 10, MsFs store version
  • PC: AMD Ryzen 5, 16 GB RAM, 1 TB SSD hard disc, graphic card: AMD RX 5700, 8 GB RAM GPU
  • USB 3.0 C to A cable for the Oculus Link connection
  • MsFs store version
  • Internet connection via LAN-cable, good connection (clearly over 50 Mbit/s).
  • Link connection in the Oculus App is good: 2.4 – 2.8 Gbps
  • Dev Mode is off

Unfortunately, for the moment I’m not able for technical reasons to show any pictures or clips, sorry! At the moment I’m pretty busy at work, so maybe I don’t have the opportunity to check your answers daily. But every help and ideas are really appreciated.

Cheers

Biggles140

I have this issue also. It would seem to be a bug for VR irrelevant of make or model. At least that’s what I’ve seen / read / heard

I’ve also read this might be a fix for SU10

We will see

Thanks for your reply! So let’s wait and see…and hope…

It sounds like you are talking about the OpenXR Tools for Windows Mixed Reality app settings?

These are for WMR headsets only, they wont do anything with your Oculus device.

Thanks for your reply, I didn’t know that.

Solution found (not by myself)!

CodeLoran69 posted in March 21: Press CTRL and KP2 (NumLock Pad) - Force apps to 45hz, disable ASW.

For me this is the solution; the shimmering, flickering and jumping disappaered!

So many thanks to CodeLoran69!