Shock Ultra New Bug: Digital Gauge Display Needles Missing (0.1.45)

With latest update of Shock Ultra plane (version 0.1.45), the digital gauge display is now broken. Digital needles of Oil Pressure, Fuel Pressure, Fuel Gal, Volts, and Amps are missing and longer working properly, causing yellow-and-red warning lights to display constantly. Also, Air-Speed-Indicator needle of MPH not matching background display gauge of KPH.

Recommend official roll-back to 0.1.40 (pre-bugs) until long-term fix. Thanks!

Delete the plane in the content manager and download it again. That fixed gauges for many people, including myself. Not sure about the new update though. The speedometer was already broken some time ago.

1 Like

Aye. I’ve tried that with no success. Then did clean install of MSFS. Then tried folder-deleting process again. There is a new Shock Ultra update (0.1.45) as of today. This introduced the new digital display gauge bug. Unable to get back to the pre-bug rollback folder.

So speedometer works now but the digital display does not? or speedometer also does not work?

1 Like

Both. Speedometer bug still remains (same bug since December), with a brand-new bug of digital display needles no longer showing Oil-Pressure/Fuel-Pressure/Fuel-Gal/Volts/Amps/etc (since latest update).

1 Like

Voted. Also I submitted a request to zendesk again. But negative to that these will catch attention of the dev team…Hope someone living in Bordeaux visit their office to notify them this issue face to face, of course, wearing a mask.:mask:


Maybe if we all email Zlin of the errors, they can have someone make a quick and friendly phone call. :slight_smile:

1 Like

all these bugs are very disappointing , cos 0.1.40 of the plane worked perfectly (speedometer ok and Digital Gauge ok too).

1 Like

that worked during the week , but now , event if we delete the plane , (even with clean install) , the updater download the 0.1.45 broken version :confused:

1 Like

The plane had issues before. The temperatures were wrong. The display was indicating that the temps were in degrees of Celcius, when in fact they were in Fahrenheit. In cruise, I was getting around 250 degrees Celcius, which is way too hot for Rotax. Rotax runs in between 100-150. Right now, the speedometer is in knots instead of km/h, but the digital gauges work perfect for me in the latest version and the indicated temps are finally in Celcius.
Basically, they screwed up the speedometer but fixed the digital display. OP, you say the display is dark for you? I have no issue here. I think it is the bug Asobo stated. Reload the flight and check again.

1 Like

All of the virtual needles on your digital display are visible and moving properly? (Oil-Pressure/Fuel-Pressure/Fuel-Gal/Volts/Amps) That’s encouraging. Only the RPM/MAP needles are visible/working for me. Oil-Pressure needle missing. Fuel-Pressure/Fuel-Gal needles missing. Volt/Amp needles missing. Thus causing the virtual display gauges to statically glow yellow and red in warning at all times instead of only turning yellow/red when needle reaches proper warning point.

Yes, all work as they should. Only the speedmometer is in knots instead of km/h.

1 Like

Copy, thanks. Its encouraging that the virtual needles are working for some folks and not a total community-wide bug. Maybe I’m getting a corrupted file from the Store?

You mean small triangular needles like this🔺? Mine is also missing.

UPDATE: with latest Delete and Re-Download of plane from Content Manager today (3/13), the digital display gauges are now working/moving for me. Though the digital needle gauges are still showing Red/Yellow warning colors at all times. The number displays/boxes are properly switching from green to yellow/red colors, yet the visual gauges are not switching properly between colors. Will keep yall posted on any changes in the near future.

P.S. ASI still bugged (MPH needle with KPH background)