SIM 5 update nightmare on controls

I guess as many of you might have noticed that the mapping buttons on the joysticks… doesn’t matter what brand, is not function anymore.
Uninstalling the joystick, re-installing, updating USB drivers, updating Windowns had no effect on this!

I’m using a Thrustmaster Hotas 4 and before the latest update, it was PERFECT !!!
Now for instance, the spoiler deployment button doesn’t function at all… even on the keyboard… you have to manually activate it with the mouse… but strangely if it is activated and i press the mapped button on the joystick… it retracts then… but doesn’t extend if I press it again…
The mouse cursor also disappears for no reason.
Also noticed that when flying, the right ailerons doesn’t move… (this is on the 787-10)
When you unplug the usb controller the Sim freezes up and you can’t do anything…
There is also the issue of liveries that makes the plane look pixelated and pink (3rd party downloads), but i guess it’s up to the person who designed it to update it again.

I guess all we can do is to see if Asobo (Zendesk helpforum) will read all these thousands of complaints and fix it soon!.. All of us have spent a s…load of money on the program and hardware for our systems to make this an enjoyable hobby…

C’mon Asosbo!!! get it right before releasing something to us… It is NOT the first time!!!
I guess you got your money and is laughing all the way to the bank…

All in all, this has come to a point where i want to start throwing things and swearing a lot!! LOL

Should anyone get any news from Asobo, please do share!

I can’t say “happy flying”… but lets hope for the best

My experience was similar to yours. My Logitech Extreme 3D Pro throttle axis no longer functions on the Cessna Longitude. And this morning I cannot even launch the program - alI I get is a big splash screen for the MS Store “Gaming Experience”. I guess the only thing is to let MS have time to fix it.

I can no longer operate any switches in the cockpit since Update 5. Very strange.

UPDATE: Fix posted in another thread

General Options > Accessability > User Interface > Cockpit Interaction System
and change LOCK to LEGACY

1 Like

Oh yes - I did that right away. That made my mouse able to throw switches,etc. But on the Longitude (Cessna jet) the joystick throttle doesn’t control the engine speed. And the overhead control panel is dark (no functionality). That was yesterday.
But today I can’t even launch the Sim itself- all I get is that Game Experience screen.

Same here.

Joystick mapping (even Keyboard mapping) is a nightmare… Maybe it’s better with a XBOX controller … LOL.

Come on ASOBO ! Wake up and test your soft BEFORE release ! We are not in a PTU version !


Asobo are just having a giraffe, oh no sorry its a rhino. All very well giving us an update but not very good if the aircraft don’t fly or won’t stay in the air. I have and a329 with only one engine running and a cessna caravan with the fuel cut off permanently shut. Seems very strange to me and if I hadn’t been flying the simulator for nearly a year and recieved it as a present I would ask for my money back.

1 Like

Nice day,
I have very, very good hardware and am unfortunately very disappointed with the update,
I fly with the A320 Hotas from Thrusmaster and even the Super Hotas no longer work properly in the standard A320, unfortunately a shame. but the Xbox version runs :smiley: SUPER

Oh, and before I forget, the download only loads at 35 to 40 Mbit / s, although everything has been done according to Microsoft’s instructions to make it faster since there is a 400 Mbit / s line :poop:

yeah this Sim Update broke a lot of things for me. It was working fine for me before, I had no noticeable performance issues and my aircraft worked. After updates it seems a lot of things are broken, for example incorrect altitude reporting to online ATC, stuck controls, inoperative switches, very glitchy. it’s to the point I can’t play the sim any more until the next patch.

1 Like

Même problème, depuis la dernière mise à jour, mon Thrustmaster HOTAS ne fonctionne plus: plus de manette des gaz et les boutons ne fonctionnent plus.

My impression is that they did it to promote the xbox for the kiddies.


Hello everyone,

exactly the same for me.
Before the update everything worked fine.

After the update, the Thrustmaster Airbus Edition (Throttel and Sidestick) do not work properly (thrust can no longer be metered). In the adventure flights, the planes crash after a short gliding.

The left engine of the A320 does not work and is therefore not flyable.
On the A320 FBW, the entire simulator crashed after the globe.

After nothing worked, I uninstalled and reinstalled everything.
Same problems, … in addition, the A320 FBW can no longer be loaded from the marketplace.

Dude … what’s going on with the Sim?
I jealously watch Youtube, who report on performance improvements.
I want my Sim back before Update 5.

Can anyone help?


Well… let’s hope this issue will be fixed after the Patch release later today!

Ok… so i downloaded the supposed fix, but there are absolutely no changes!!! Mapped buttons on my joystick still don’t work… I’M FED UP… these people made millions of $ with this sim and this is what the customer gets… premature releases of updates… whoever the guy is that is testing the updates needs to be sacked!!
I am sure they have a deadline for releasing an update and come hell or highwater they will just release something to make them look good… nevermind the problems it might cause, because surely they will butter it up by saying… "ooooo we have an improvement “patch” hotfix… or what the F else, just to get everyone’s hopes up…
Asobo… get you act together!!! I can’t believe that Microsoft allows this…

I have just deleted the entire MSF2020 file on my PC and downloading it and doing a fresh install again!!! … I’m not getting my hopes up that this will work…

Same Problems here. The Performance is mutch better. But the all other is fuc… up. Hardeware Binding, Switches, nothing work like bevor.

LG Chris

I’m having issue with the camera view and the mouse clicks work whenever they feel like it. I cannot operate any of ,y community aircraft and yes they’ve all been updated

In regard to the update on July 29, 2021:

I’m having same problem. Flying with automation doesn’t work with many aircraft I tried.
I have a fast i7 computer with 16GB RAM, a new Thrustmaster joystick and fast SSD drives. Previous version working fine. Everything is messed up now.

I prefer the Lock mode than the Legacy mode. But both have problems in different planes.

In lock mode, the following aircraft’s heading and speed knobs don’t do anything. It doesn’t matter whether autopilot is on or off. Also, In the 747, the Heading Hold button gets stuck ON, but regardless it’s only possible to change heading by disengaging autopilot and manually steering with the joystick. This is true in the following planes:

Airbus A320
Boeing 787
Boeing 747
Both Cessna Jets (CJ4 and Citation Longitude)

These are only the ones I know don’t work, haven’t tried them all.
Also, I’ve found that, after landing and parking, I cannot turn off the airliners even though
I shut off all the electrical circuits the plane remains powered. This is true for the A320, the 787 and, I think, the 747.

The only plane I’ve flown, so far, that does work correctly is the Beechcraft Bonanza G36. But this plane has some new never- before-seen graphic glitches that puts weird artifacts in the sky.

I’ve had all kinds of irratic behavious post SU5, and sometimes the issues just come and go.

I have a TM TCS HOTAS with throttle and pedals. There were times when the elevator trim was badly messed up, making flying just about impossible. And times when buttons would just do nothing or things they were not assigned to do. Maddening.

But, without doing anything it was all working fine last I flew last night. But I’m still getting CTDs randomly. Sometimes I get 40 minutes of flying in before a CTD, other times it’ll CTD repeatedly, including on loading the sim before even getting to the main screen.

Asobo really needs to get it together. This is infuriating. And just embarrassing for them. Are all these issues hitting new XBox users too? Or are we suffering because all the changes made for XBox added tons of bugs and they ignored those because they just had to meet the XBox release deadline. The fps increases are pretty awesome, but they don’t make up for the fact I have to keep restarting after CTDs I spend as much time reloading the sim than I do flying. I think I may just have to stop trying until there’s another hot fix or more major update and everyone is reporting MUCH better reliability.

I think they need to do a feature freeze and pause all world updates for 3 or 6 months and just make sure this software actually works consistently, reliably!

What a mess.


I’m using a Logitech Extreme 3D Pro and I have no pitch control with my Black Box Simulation Cessna L-19 bird dog. The elevator moves up and down but the aircraft doesn’t respond. The keyboard controls have the same results. It flew just fine before
SU5. All the other planes I have fly normal.

The rudder is inoperable for me after landing on any aircraft.

1 Like