Sim freezes at 'New Activities". Will not load to home screen

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

3 days ago it was working fine. Next day it just freezes at the “New Activities” screen. I re-installed 2 times since then and the same issue. It is through Steam. Is anyone else experiencing this?

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Just started the sim 3 days ago and I got what’s in the screenshot.

PC specs and/or peripheral set up if relevant:

Asus Maximus 12 Hero, 10900K , 64 Gigs ram , 3090.

Build Version # when you first started experiencing this issue:

Latest build


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

No extra info.

If relevant, provide additional screenshots/video:

An update to this post. I emptied out the community folder and re-installed the sim twice in the last few days, I don’t know if that helped but I think it came down to sound driver. I disabled every mention to sound in Device Manager and I installed the original Realtek driver from my MB’s website. So far it’s working. I’m slowly putting things back in the community folder and I’m able to get to the home screen and the sim works. I’m not sure if this is going to be the end all but I hope this helps someone else with the same problem. Stay well guys.

Ok so it didn’t work. I un-installed it again and re-installed on a different drive. Still no good. I can’t get by the “Activities” screen and the blue loading bar goes to the end and just sits there… How can it go from working one day and in less than 24 hrs to not working??? I’ve never had this problem with another piece of software at all. I’m at a complete loss! I would appreciate any kind of help. This is simply ridiculous.

Here is a link to the checklist for this problem:

Ok. So I’ve re-installed windows twice. I’ve re-installed the sim 3 times. The last time on my C drive instead of my D drive ( which I’ve had installed on since I bought it ). It started normally 3 times today…7\17 so I started to install from the content manager. Started it back up and it worked. I exited the sim and stepped away from the computer for about an hour. Got back, started the sim again and now it just hangs at the new activities screen again. I went through the trouble shooting guide and still nothing. I even tried to start from the executable from the steam folder and still hangs. Can someone please explain this to me??? I understand software can be funny sometimes…but not like this. Why is it so much trouble just to get this thing to work? I’m sorry but this whole thing is a mess. So I have a sim, that I paid for and it can’t be used. This is just wrong in every way.

2 Likes

I updated this on another post. I came across a solution for me and maybe others. I have wifi on my MB. I unplugged the ethernet cable from my MB and am running just on wifi. That solved the freezing screen for me and can run the sim fully now. I hope this can help someone.

1 Like