Sim says update in store...None there! This solution worked for me...twice

For the PC…Store version…Not Dev mode.

After update 5, sim reported there was an update in the store. There was no update there.

Tried several suggested fixes from the forums. What finally worked was to uninstall sim after renaming the (well-loaded) community folder.

After the re-install, I deleted the newly created Community folder and renamed my backup to “Community”. I started the sim and was able to load to the main menu and proceed, successfully, to perform all in-sim updates.

Everything was fine until the release of the next patch…where I had to repeat all of the above. The re-install worked both times.

The re-install was not so bad, considering my Gb internet connectivity…lucky for me…smiles. And my PC is an i-9 with 64 Gb ram running a 1 Tb NVME M.2 running Sli 2070’s.

Anyway…working again now with everything…so far.

By doing this you are not getting to the root of the problem and possibly causing inexperienced users much frustration. In my opinion, you have taken the nuclear option.

Instead look to:

  1. proper log-in credentials
  2. XBOX App correct installation and registration first
  3. correct STORE installation and integration

This topic has been covered many times already, including on the Microsoft official pages of this game.