Sim stuck after pause

So I just ran into a curious issue that’s never happened before. In the sim (doesn’t happen before clicking “Ready to fly”), when I hit the ESC key to pause and then ESC again to unpause, the “plane” will not resume, even though the game and the sim keeps running. So I can move the camera, adjust the weather, even speed up or slow down the sim rate (visible through a fast sunset), but the plane itself won’t move. I can adjust throttle and see the RPM pointer change, but no effect on the plane, and the engine noise doesn’t change when I move the throttle.

I’m not in active pause (I’ve toggled it both via the bar option and via keystroke), and I’ve use the “pause/resume” options via the developer menu, but it hasn’t helped.

Curiously, using the developer menu and the “show location” option, I can see that the plane is climbing ever so slightly - the altitude above ground level is increasing by about 0.00001 meters a second (while the even smaller numbers are rolling rapidly). If I reduce throttle all the way, the altitude stabilizes then drops by a similar minuscule amount. It’s almost like the world is running at 1x time and the plane is running at 0.00001x time.

The only way to break out is to quit to menu or restart the flight. I’ve restarted the game and also rebooted the system. Have also plugged and unplugged all the USB joysticks and such, except my Logitech keyboard. Can consistently repeat by starting a flight, and then hitting ESC+ESC.

Any ideas??

Like you I press esc to pause; however, that returns me to the start screens where I can choose controls, graphics, assistants, etc. To resume, I use CNTRL-P.

Thanks. I tried Ctrl-P also and it didn’t work.

In the past ESC/ESC worked perfectly, although I haven’t played in a while. Not sure if something changed or something got messed up with one of the sim/world updates.

One of the updates changed esc/esc to esc/cntrl-p. Are you sure you’re up to date on all the updates?

Yeah, I just did all the updates all the way through the new WU 10 (USA).

I’ll give it another shot with Ctrl-P. It’s weird though that ESC gets me back to the sim, just with the plane still paused.


Ctrl-P didn’t work for me, but what I did was to unbind ESC from all keys, and then re-bind them according to default values.

My fix, in case it’s useful to someone else later:
I originally had ESC bound to ‘toggle pause’, ‘set pause on’, and ‘set pause off’. (This never gave me problems until now).
The default profile had ESC bound only to ‘toggle pause’ and ‘set pause off’.
After re-binding, things appear to be back to normal.